All users were logged out of Bugzilla on October 13th, 2018

[Build bustage|Windows] ERROR: The SDK in WINDOWSSDKDIR (C:\Program Files (x86)\Windows Kits\8.1\) does not contain the Universal CRT.

RESOLVED DUPLICATE of bug 1291140

Status

--
blocker
RESOLVED DUPLICATE of bug 1291140
2 years ago
8 months ago

People

(Reporter: mayhemer, Unassigned)

Tracking

({regressionwindow-wanted})

Trunk
All
Windows 10
regressionwindow-wanted

Firefox Tracking Flags

(firefox51 affected)

Details

(Reporter)

Description

2 years ago
Current m-c, windows 10, SDK 8.1, relatively simple mozconfig

 ...
 0:16.93 checking for Universal CRT SDK... no
 0:16.93 ERROR: The SDK in WINDOWSSDKDIR (C:\Program Files (x86)\Windows Kits\8.1\) does not contain the Universal CRT.
 0:16.95 *** Fix above errors and then restart with\
 0:16.95                "c:/Mozilla/mozilla-build/mozmake/mozmake.EXE -f client.mk build"
 0:16.96 c:/Mozilla/src/mozilla-central/client.mk:373: recipe for target 'configure' failed
 0:16.96 mozmake.EXE[2]: *** [configure] Error 1
 0:16.96 c:/Mozilla/src/mozilla-central/client.mk:390: recipe for target 'c:/Mozilla/src/mozilla-central/_obj-browser-debug/Makefile' failed
 0:16.96 mozmake.EXE[1]: *** [c:/Mozilla/src/mozilla-central/_obj-browser-debug/Makefile] Error 2
 0:16.96 client.mk:168: recipe for target 'build' failed
 0:16.96 mozmake.EXE: *** [build] Error 2
 0:17.02 0 compiler warnings present.
2


Tried to reinstall the SDK 8.1, didn't help.  Going to changeset fef429fba4c6 helped.  But I'm not sure what is the exact regression range.

Comment 1

2 years ago
This is likely from 656febbe6d05 (bug 1289291).

Do you not have the Windows 10 SDK installed (c:\Program Files (x86)\Windows Kits\10\)? Configure is looking for a Windows 10 SDK to find the Universal CRT (which was introduced in that SDK release). Since it can't find one, it is bailing.

If you do have the Windows 10 SDK installed, the next question becomes why configure is finding the 8.1 SDK instead of the 10 SDK.
Depends on: 1289291
Flags: needinfo?(honzab.moz)
(Reporter)

Comment 2

2 years ago
(In reply to Gregory Szorc [:gps] from comment #1)
> This is likely from 656febbe6d05 (bug 1289291).

Will confirm tomorrow.

> 
> Do you not have the Windows 10 SDK installed (c:\Program Files (x86)\Windows
> Kits\10\)? 

No, and I think never had on the affected machine.

> Configure is looking for a Windows 10 SDK to find the Universal
> CRT (which was introduced in that SDK release). Since it can't find one, it
> is bailing.
> 
> If you do have the Windows 10 SDK installed, the next question becomes why
> configure is finding the 8.1 SDK instead of the 10 SDK.

Would more detailed build log help?  Would mach -v build -v help?  I can provide more info all tomorrow (just leaving)
This looks like a dupe of bug 1291140.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(honzab.moz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1291140

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.