Status

()

RESOLVED DUPLICATE of bug 1261900
2 years ago
2 years ago

People

(Reporter: joeyparrish, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(firefox48 affected, firefox49 fixed)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

Steps to reproduce:

1. Load WebM-only DASH content in Shaka Player by visiting http://nightly.shaka-player-demo.appspot.com/demo/?asset=//storage.googleapis.com/shaka-demo-assets/sintel-webm-only/dash.mpd
2. Click "Load"


Actual results:

Playback hangs around 10-14 seconds.


Expected results:

Playback should continue, as it does for the MP4-only variant of the same stream:

http://nightly.shaka-player-demo.appspot.com/demo/?asset=//storage.googleapis.com/shaka-demo-assets/sintel-mp4-only/dash.mpd

Updated

2 years ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
I can reproduce in Firefox 48 but not in 49.
status-firefox48: --- → affected
status-firefox49: --- → fixed
(Reporter)

Comment 2

2 years ago
Awesome, thanks.  Will a fix be backported to 48, or should I just wait for 49?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1261900
(In reply to joeyparrish from comment #2)
> Awesome, thanks.  Will a fix be backported to 48, or should I just wait for
> 49?

WebM/EME isn't supported in 48. Are there any production sites that use Shaka player with WebM but don't require EME?
(Reporter)

Comment 5

2 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #4)
> WebM/EME isn't supported in 48. Are there any production sites that use
> Shaka player with WebM but don't require EME?

Unfortunately, I don't know the answer to that.  As an open-source project, we only know details of production apps if their authors happen to tell us.

We have many WebM assets in our demo app, and we run automated tests over those assets.  Our tests are failing on Firefox, so it would be nice if we could see them passing sooner.  But it's not critical, and we can wait for 49.
You need to log in before you can comment on or make changes to this bug.