Search functionality not working from widget for custom default engines

RESOLVED WONTFIX

Status

P3
major
RESOLVED WONTFIX
2 years ago
9 months ago

People

(Reporter: saul.kredi, Unassigned, NeedInfo)

Tracking

({qablocker})

48 Branch
All
Android
qablocker

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8777109 [details]
After typing search term

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

I added Firefox Search widget to my Android 6.0.1 device homescreen.
My FF default search provider is Startpage.com.
I tap the widget seach part, and it's open a the search screen.


Actual results:

It's open a the search screen, with search input field and a gray empty area below.
When I start typing a string nothing happens. I can't see any suggestions or search history. Even after I tap the search button nothing happens.
Just after I press the return button [that hide the keyboard (AnySoftKeyboard)], I can see some search history but no results. 
I have also have also Orfox 38.0 installed on the same device, and there widget working fine with the same search provider.


Expected results:

I should see some search history, and when press the search button to execute the search and get results.
(Reporter)

Comment 1

2 years ago
It occurred also in version 47.x.
(Reporter)

Updated

2 years ago
OS: Unspecified → Android

Comment 2

2 years ago
Hi Saul,

I'm not able to reproduce this using Nexus 9(6.0.1) on latest release(48), beta, nightly and aurora. It works fine for me.

Can you please try it again and maybe provide more steps to reproduce this?

Thanks
Component: General → Search Activity
Flags: needinfo?(saul.kredi)
(Reporter)

Comment 3

2 years ago
Hi Alex,
Now I see that it's working fine with Google Search, so this is important step to change search provider to StartPage.com.
I don't really have more steps, but I will write it again more detailed.
1. Install Firefox from Google Play Store.
2. Add StartPage search provider as default to FF:
   - One option install from here:
     https://addons.mozilla.org/en-US/firefox/addon/startpage-privacy-search-engin/?src=ss
   - Other option is to go to startpage desktop site, and tap "Add StartPage to Firefox" and follow    instructions.
3. Add Firefox widget to home screen.
4. Tap the search button on FF widget.
5. The FF search app will open, and you see search box, no search history (even if you searched before), and the keyboard (I'm using AnySoftKeyboard).
6. Tap return button and you will see history.
7. In the FF search application try to search for something, and the search result page, won't load up.
Flags: needinfo?(saul.kredi)

Comment 4

2 years ago
Hi Saul,

I did all the steps using AnySoftKeyboard and can't reproduce it on 48 Release with Sony Xperia Z5 Premium and Samsung Galaxy Note 5. I will close this bug, but please make sure to reopen if you will see this again.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

2 years ago
Hi Alex,
This bug still exists in my HTC 10 device.
I would be happy to help with this issue.
Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

2 years ago
Hey,
I am able to reproduce it with the steps from comment 3 - on my Nexus 5X (Android 6.0.1)
The odd thing is that this reproduces with all custom made default search engines. 

We will look for a regression window. 

Thanks for the report Saul K!
Severity: normal → major
Status: UNCONFIRMED → NEW
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
Ever confirmed: true
Keywords: qablocker, regressionwindow-wanted
Hardware: Unspecified → All
Summary: Search functionality not working from widget → Search functionality not working from widget for custom default engines

Comment 7

2 years ago
One small step in between:
3.1 After you change the default search engine - close the Firefox Process (swipe app from recent apps) - due to Bug 1131087

Comment 8

2 years ago
Verified using: Samsung Galaxy Note 5 with Nightly 45.0a1

Last good build: 2015-10-30
First bad build: 2015-10-31

Enter push log:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b41b92c09fcf94d077a54297aea1dc675b161a9d&tochange=c1a94d5365e48f86de6a7bb6a3c4c7d82b9d660e
(Reporter)

Comment 9

2 years ago
I'm glad I can help.
BTW, the widget of Orfox 38.0, is working fine with custom default search provider, if it help to solve the issue.
(Reporter)

Comment 10

2 years ago
What's going o with this bug?
Anthony, I've seen you've been assigned on bugs from this component. Can you please help us here (there are steps to reproduce in comment 3), or redirect to somebody you think could have a look, or reassign to another component? Cheers!
Flags: needinfo?(alam)
Hey Benjamin! 

I'll CC product here to decide on next steps and prioritization since this seems to be a bug.
Flags: needinfo?(alam) → needinfo?(bbermes)
(Reporter)

Comment 13

2 years ago
Any updates?
status-firefox54: --- → affected

Updated

a year ago
tracking-fennec: --- → ?
status-firefox55: --- → affected
status-firefox56: --- → affected
Keywords: regressionwindow-wanted
We are not working on search widget now. But someday we need to fix it.
tracking-fennec: ? → +
Priority: -- → P3
This is an ex-Search Activity now (bug 1221344).
Status: NEW → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → WONTFIX

Updated

9 months ago
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.