Responsive design mode icon is similar with dock to bottom icon

RESOLVED FIXED in Firefox 52

Status

()

Firefox
Developer Tools
RESOLVED FIXED
11 months ago
5 months ago

People

(Reporter: magicp, Assigned: helenvholmes)

Tracking

unspecified
Firefox 53
Points:
---

Firefox Tracking Flags

(firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox51 wontfix, firefox52 verified, firefox53 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 months ago
Created attachment 8777256 [details]
responsive-design-mode-icon-is-similar-with-dock-to-bottom-icon.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

1. Start Nightly
2. Open DevTools
3. Move dock to side


Actual results:

Responsive design mode icon is similar with dock to bottom icon.


Expected results:

Responsive design mode icon should be changed to more identifiable like firebug icon.
(Reporter)

Updated

11 months ago
Has STR: --- → yes
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
Component: Untriaged → Developer Tools
OS: Unspecified → All
Hardware: Unspecified → All
They are indeed very similar!  Helen, any thoughts about this?
Flags: needinfo?(hholmes)
(Assignee)

Comment 2

11 months ago
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #1)
> They are indeed very similar!  Helen, any thoughts about this?

In this bug's current form I would consider this a WONTFIX—they're separated out into two separate sections.

However, I can see how in this mode, the visual separator disappears, which is problematic: https://cl.ly/2F1s1u0v0t2Y

gasolin is currently working on a series of toolbar visual changes that should resolve this bug by removing background colors on the panel backgrounds and using color on the text instead, which will preserve that visual separator and making these two buttons more obvious with the Settings panel selected.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(hholmes)
Resolution: --- → WONTFIX
(Assignee)

Updated

7 months ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 3

7 months ago
Created attachment 8811405 [details] [diff] [review]
rdm-icon.patch
Attachment #8811405 - Flags: review?(jryans)
(Assignee)

Comment 4

7 months ago
Created attachment 8811406 [details]
Screen Shot 2016-11-16 at 1.51.07 PM.png

With the patch applied.
status-firefox48: affected → wontfix
status-firefox49: affected → wontfix
status-firefox50: affected → wontfix
status-firefox51: affected → wontfix
status-firefox52: --- → affected
status-firefox53: --- → affected
Comment on attachment 8811405 [details] [diff] [review]
rdm-icon.patch

Review of attachment 8811405 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for working on this!

Please add r=jryans to commit message.

::: devtools/client/themes/images/command-responsivemode.svg
@@ +1,4 @@
>  <!-- This Source Code Form is subject to the terms of the Mozilla Public
>     - License, v. 2.0. If a copy of the MPL was not distributed with this
>     - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
> +<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="16" height="16" viewBox="0 0 16 16" stroke="#0b0b0b" stroke-miterlimit="10" stroke-wdith="2" stroke-linecap="round" stroke-linejoin="round" fill="transparent">

Looks like the following attributes are not needed:

* xmlns:xlink
* stroke-wdith (which is misspelled and distorts the image if corrected)

These I am less sure about, but I could not notice an obvious change when removing them:

* stroke-linecap
* stroke-linejoin
Attachment #8811405 - Flags: review?(jryans) → review+
Assignee: nobody → hholmes
Status: REOPENED → ASSIGNED

Comment 6

7 months ago
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/42de50438fc9
Adds new responsive design mode icon. r=jryans
https://hg.mozilla.org/releases/mozilla-aurora/rev/7ad438df2992
status-firefox52: affected → fixed

Comment 8

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/42de50438fc9
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago7 months ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
(Reporter)

Comment 9

7 months ago
This bug was verified fixed in latest Aurora and Nightly build. Thanks!
status-firefox52: fixed → verified
status-firefox53: fixed → verified

Comment 10

7 months ago
https://hg.mozilla.org/mozilla-central/rev/42de50438fc9

Updated

5 months ago
Depends on: 1338363
You need to log in before you can comment on or make changes to this bug.