PGP-Encrypted and S/MIME-signed messages not displayed, TB keeps painting/blanking the PGP info bits

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
a year ago
11 months ago

People

(Reporter: Andre Muller, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8777267 [details]
Message_PGP-Encrypted_and_SMIME-Signed.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160708164131

Steps to reproduce:

I'm using a mailbox in which all messages are PGP-encrypted (i.e. my Provider uses
my Key to encrypt all incoming messages). When I get messages that are signed using S/MIME, the messages are not displayed. Taking the mail source and 
decrypting manually with gpg works. I will attach the source for an example message and a decrypted version of the PGP block therein.


Actual results:

When getting PGP-Encrypted and S/MIME-signed messages, the PGP UI Elements keep popping up and disappearing forever. 


Expected results:

The message should be displayed, security info should be accessible.
(Reporter)

Comment 1

a year ago
Created attachment 8777269 [details]
Decrypted_PGP-Block.txt
Thunderbird itself does nothing with PGP, this is handled by the Enigmail add-on. Do you have that installed and do you still have this problem? Then it's best to check with Enigmail support: http://enigmail.net/index.php/en/support/reporting-defects
Flags: needinfo?(andre.muller)
(Reporter)

Comment 3

11 months ago
Yes, I have the Enigmail plugin installed.
I will go ahead and report to enigmail
as per your suggestion.

Thanks!

Comment 4

11 months ago
That's a known issue in Enigmail.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(andre.muller)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.