Mozilla will not load this at all, or any other page based on our templates (consistent); trouble with others too (inconsistent)

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
--
major
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Stanton McCandlish, Assigned: Darin Fisher)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I am using the latest milestone build (available from the "Download" link on your front page; I'm not using a 
nightly build).  MacOS 9.2.2, G4, loads of RAM.

Attempting to connect to http://www.eff.org/ and subpages such as http://www.eff.org/support/ that are 
based on the same set of templates results in Mozilla apparently doing nothing at all.  It does not appear to 
even load a portion of the source (i.e. if you begin at some other page, such as this one and then attempt to 
go to ours, you remain at whatever page you are at.)

One exception is http://www.eff.org/br/ which is based on a slightly different template (one that allows for 
black background, different text colors, calls a different stylesheet, etc.)  In this case, Mozilla loads a fraction of 
the page, but not all of it.

Sometimes this is also happening with other sites.  For example, when I started up Mozilla an hour ago, it 
connected to your site as the default home page with no problem.  I was also able to view some of the 
eff.org pages that date to 1996 or so and are not in our newer templates.  I quit Mozilla and restarted it, and 
now it does NOT load the mozilla.org front page, by default or on reload.  When I try to go to 
http://search.netscape.com/search.psp?search=http%253A//www.mozilla.org/start (by clicking the search 
button next to the URL entry box in Mozilla), it loads a wee bit of the page (view source shows that the file is 
truncated at ">Personal Finance</option>").

None of this used to be happening.



Our newest
(Reporter)

Comment 1

17 years ago
To continue my truncated text:

Our newest basic template is here:

http://www.eff.org/templates/template-basic.zip

The more "maximal" one that our front page is based on is here:

http://www.eff.org/templates/template-inset-sidebar.zip

And the one that http://www.eff.org/br/ is based on is here:

http://www.eff.org/templates/b-template-inset-sidebar.zip

These are ZIPped because the HTML has SSI commands in it.

Anyway...

If anyone thinks this is just due to something about my system config,
I'm certainly open to ideas about how to resolve this problem.
The only thing odd or different I've done with Mozilla is replace
its Plug-Ins directory with an alias to the Netscape one to save
disk space, and replacing the search sites directory with an alias to
my System Folder:Internet Search Sites folder, so that all my
Sherlock plugins are available to Mozilla.
(Reporter)

Comment 2

17 years ago
I tried using Open Web Location to open http://www.eff.org/ in a new window. This time I actually
DID get some of the source.  The results are quite bizarre:

[being source]
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN"><html><head><title></title></head><body></body></html>
[end source]

That's it!
(Reporter)

Comment 3

17 years ago
I just tested this with Netscape 6..1 and the same thing is happening (with minor difference)!

[begin source]
<html><body></body></html>
[end source]

That's all it thinks the page contains.

What's going on here??  Earlier versions of Netscape 6 were not doing this with our site!
(Reporter)

Comment 4

17 years ago
That should have read "Netscape 6.2.1", sorry.

Comment 5

17 years ago
Mac problem only? WFM using 2002 03 05 08 / win2k
(Reporter)

Comment 6

17 years ago
I'm still getting it, after a restart.  I can (usually) get to any www.mozilla.org page (though not 
bugzilla.mozilla.org) and SOME other pages here and there on the net (not yahoo.com, not obscure.org,
but I can get http://www.eff.org/IP/DMCA/, and I can get slashdot.org.)  The ones I can't get show up as 
empty of content other than a few tags, as reported earlier.  In the case of obscure.org I got quite a bit more, 
including body content (including tables and such), but the content truncates like so:

[...]
 <a class="navbar" href="/info/members.shtml">members</a><br>
&#8226;<br>
<a class="navbar" href="/info/projects.shtml">projects</a><br>
&#8226;<br>
<a class="navbar" href="/info/lists.shtml">lists</a><br>
&#8226;

Actually in the case of the EFF pages I can't get, I don't get anything at all (not even broken source), unless I 
load the page in a new, blank window via Open Web Location (or presumably by turning off the homepage 
"feature" that loads the default homepage into every window I open, which I will be turning off because it's 
useless and annoying. >;-)  When I do this and get the broken EFF content it is always consistently:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN"><html><head><title></title></head><body></body></html>

Curious thing is, this is not even from our page.  My doctype reads:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 
"http://www.w3.org/TR/REC-html40/loose.dtd">


Could this have something to do with the doctype definition?

I have confirmed that a "recent" (dunno build no.) Linux version of Mozilla has no trouble with these pages; 
I've even seen screenshots to prove it.

Whoops, actually now I *can't* get all www.mozilla.org pages (only some of them), but I *can* get 
bugzilla.mozilla.org now.  <sigh>  The EFF pages I can't get, however, are NEVER gettable.
(Reporter)

Comment 7

17 years ago
I'm still getting it, after a restart.  I can (usually) get to any www.mozilla.org page (though not 
bugzilla.mozilla.org) and SOME other pages here and there on the net (not yahoo.com, not obscure.org,
but I can get http://www.eff.org/IP/DMCA/, and I can get slashdot.org.)  The ones I can't get show up as 
empty of content other than a few tags, as reported earlier.  In the case of obscure.org I got quite a bit more, 
including body content (including tables and such), but the content truncates like so:

[...]
 <a class="navbar" href="/info/members.shtml">members</a><br>
&#8226;<br>
<a class="navbar" href="/info/projects.shtml">projects</a><br>
&#8226;<br>
<a class="navbar" href="/info/lists.shtml">lists</a><br>
&#8226;

Actually in the case of the EFF pages I can't get, I don't get anything at all (not even broken source), unless I 
load the page in a new, blank window via Open Web Location (or presumably by turning off the homepage 
"feature" that loads the default homepage into every window I open, which I will be turning off because it's 
useless and annoying. >;-)  When I do this and get the broken EFF content it is always consistently:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 
Transitional//EN"><html><head><title></title></head><body></body></html>

Curious thing is, this is not even from our page.  My doctype reads:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 
"http://www.w3.org/TR/REC-html40/loose.dtd">


Could this have something to do with the doctype definition?

I have confirmed that a "recent" (dunno build no.) Linux version of Mozilla has no trouble with these pages; 
I've even seen screenshots to prove it.

Whoops, actually now I *can't* get all www.mozilla.org pages (only some of them), but I *can* get 
bugzilla.mozilla.org now.  <sigh>  The EFF pages I can't get, however, are NEVER gettable.

Comment 8

17 years ago
what you're getting is the source for about:blank, why you're getting it? 
*shrug* presumably something failed to load or view-source had issues.

i'd suggest dom inspector, but most likely it'd show the same thing.

there's nspr logging, but i doubt your build exposes it ...
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever

Comment 9

17 years ago
I think I have experienced something similar with recent nightlies.
2002030412 trunk for MacOS9.2
1. In Preferences|Privacy&Security|Validation|, "validate with OSCP" is turned off.
2. Goto
http://store.britannica.com/escalate/store/DetailPage?pls=britannica&bc=britannica&pc=EB_Comptons_2002&pls0affiliate_id=adtracking&pls1adtracking=POPUPCOMPTONS
3. Click "Add to Cart"
4. Click "Checkout"
Result: Most of the time, loading of the next page is incomplete.
I do not think it was happening in the builds before 20020220.
(Reporter)

Comment 10

17 years ago
Still happening in build 2002030608.  :-(

(That is, my inability to load the http://www.eff.org/ page; I didn't try the Britannica site).
Bradley, could this be related to the FTP bugs you've been getting?
No longer blocks: 129467
Its a mac, so it could be bug 129364 + friends.
(Reporter)

Comment 13

17 years ago
Apparently this is a false alarm on my part.  I got access to two other Macs and tested this out on them,
and it worked fine.  I also noticed that IE on my machine (the one where the problem I reported was
happening), gives an SSI error when looking at the same page.  The other techies around here and
I have arrived at the conclusion that something about my system configuration that we can't figure out
yet is causing my browsers to connect to our server incorrectly somehow, such that the server is not
responding with what it is supposed to be responding with.  Any ideas welcome.   Anyway, I'm closing
this (now known to be non-Mozilla) bug down.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 14

17 years ago
verified per reporters comments
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

17 years ago
Well, the SSI problems have been fixed, and MSIE has no difficulty with these pages. Yet, Mozilla and 
Netscape 6 STILL will not load these pages, on my G4.  I continue to get the source for about:blank.  Our 
server logs show a successful, nothing-out-of-the-ordinary hit.  It appears, then, that our server is correctly 
sending out the file, and it is being received, but then discarded, but only on this one machine (and other 
machines, presumably, with the same configuration quirk that's triggering this bug, which may well be a Mozilla 
bug after all).  As mentioned before, I CAN successfully load this page in Moz/NS on another Mac, just not 
this one.  Which is driving me nuts, because I need to, to test our pages on multiple platforms... 

I've tried everything I can think of, and nothing helps.  I'll be happy to answer config-related questions and 
such.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 16

16 years ago
wfm, 2002052917, Mac OS 9.1

Comment 17

16 years ago
WorksForMe using FizzillaCFM/2002071508.

Stanton, can you reproduce this problem using a new Mozilla user profile?

Comment 18

16 years ago
WFM by previous comments and own test on Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.1b) Gecko/2002090311.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 19

16 years ago
*** Bug 129467 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.