IFrames are re-sourced when the zindex attribute is set

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED INVALID
16 years ago
10 years ago

People

(Reporter: Sandip Chokshi, Assigned: jst)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DIGBug, URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    20011019

This URL demonstrates the bug:
http://jazz.netscape.com/users/sandipc/publish/ns6/IFrameZIndex.htm

This URL is only accesable inside of the firewall.  I've also attached the two
test files for those outside of the firewall.

Reproducible: Always
Steps to Reproduce:
1.See the above URL or attachments

Expected Results:  a. Setting the zindex shouldn't re-source the iframe.
b. The document reference shouldn't become invalid
c. Iframe's shouldn't get re-sourced across page refreshes.
(Reporter)

Updated

16 years ago
Whiteboard: DIGBug
(Reporter)

Comment 1

16 years ago
Created attachment 72693 [details]
The main test file
(Reporter)

Comment 2

16 years ago
Created attachment 72694 [details]
IFrame HTML

Comment 3

16 years ago
I see the error message in the console saying hide() not a function. Marking 
this bug invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
This bug is NOT INVALID!  I just ran the test with the above URL and it 
resulted in zero errors in the console?  How are you running the test?  It 
should be as simple as clicking the URL I provided.

Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

16 years ago
setting the el.style.zIndex = '<integer>' instead of empty string will output 
the expected result. Marking Invalid. Please reopen if you disagree.

For details please visit 
http://www.w3.org/TR/REC-CSS2/visuren.html#propdef-z-index
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
(Assignee)

Comment 6

16 years ago
I don't know whether or not this is invalid, haven't had a chance to look, but
it sounds to me from reading the description that this would be fixed by the fix
for bug 52334.
jst: he is using hide on an iframe which has other problems, notably that an
iframe with a style="visibility:hidden;" is not hidden, but I don't think this i
related to the display:none foobar.

Reporter: The file
http://jazz.netscape.com/users/sandipc/publish/ns6/IFrameZIndex_Dialog.htm has
invalid html. The script is located outside of the <html>...</html>. Does the
alert still fire if you use valid html in the iframe's document?
(Assignee)

Comment 8

16 years ago
Ah, thanks for clarifying that, Bob.
Created attachment 72960 [details]
iframe with top instead of parent
Created attachment 72961 [details]
test page containing attachment 72960 [details] in iframe

Note that the iframe is not properly hidden. The reason the iframe appeared to
have  'resourced' in the original file was the incorrect use of the
parent.functionref rather than top.functionref. In this examples there is no
error due to undefined functions and clicking on the link no longer causes the
iframe to reload.

Comment 11

16 years ago
johnny,

in my comment 5, i mentioned about the z-index. I changed 
el.style.zIndex = '0', and saw the expected result. 
And regarding style="visibility:hidden; not hidden may be other bug.
(Reporter)

Comment 12

16 years ago
Hi Bob.

In your comment #7, parent.functionFoo and top.functionFoo are the same 
because parent === top.  Plus, I don't think using parent is invalid. Its 
actually required if the HTML is a more complicated page with multiple levels 
of frames nesting.  I changed your test case to use parent instead of top and 
it still worked as expected.  The problem appreas to be related to setting the 
zindex='' vs. zindex='0' as mentioned in sirvikan's comment.

I was under the impression that setting css attributes to '' sets the 
attribute back to its default value.  Not sure if this holds true for this 
attribute or not.  In either case, the re-sourcing is a nasty side-effect that 
leaves document references invalid.

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.