Closed Bug 1291789 Opened 8 years ago Closed 8 years ago

NTLM Automatic Authentication Fails for Trusted URIs

Categories

(Core :: Networking: HTTP, defect)

48 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1291700

People

(Reporter: hgpot33, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

Steps to reproduce:

Before Firefox 48 (upgraded last night), we were able to access our Intranet sites which make use of automatic log in via NTLM. We have two Intranet websites (on two entirely different servers) which both use this method of automatic log in, which were working fine with 47 and no longer with 48. I have tried with and without the network.automatic-ntlm-auth.trusted-uris and the network.negotiate-auth-trusted-uris settings. 


Actual results:

Log in prompt


Expected results:

Automatic log in using NTLM
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
We have the same issue here. Using Firefox with network.automatic-ntlm-auth.trusted-uris settings to automaticly authenticate on different SharePoint sites and other NTLM enabled Intranet sites in our internal Network. Used perfectly fine on Win10, Win8.1 and Win7 clients until some of the Clients have updated to Version 48. The updated Clients got the same issue described by hgpot33@gmail.com. Others still work.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.