Closed Bug 12918 Opened 21 years ago Closed 21 years ago

Missing PR_IMPORT functionality

Categories

(NSPR :: NSPR, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 12913

People

(Reporter: kent, Assigned: srinivas)

Details

prtype.h includes macros for PR_EXTERN and PR_IMPLEMENT for
exporting symbols through a DLL boundary in a cross-platform
manner.  It would be nice if the symetric functionality
existed for importing symbols from a DLL.  For instance, a
simple (Win32 only) example:

#ifdef _WIN32
#    define PR_IMPORT(__type)    __declspec(dllimport) __type
#else
#    define PR_IMPORT(__type)
#endif
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
jband@netscape.com already filed bug #12913 for this
feature request.

*** This bug has been marked as a duplicate of 12913 ***
cleaning up: VERIFY duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.