print preview doesn't work for bugzilla image attachment

RESOLVED WORKSFORME

Status

()

Core
Print Preview
P1
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Jeremy M. Dolan, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
print preview doesn't show the image at the above URL. just page headers/footers.

Comment 1

17 years ago
The image doesn't appear because it is being reflowed to a size 0,0

The problem is that during reflow of the image the image is null.

In this code, the "con" comes back null, inside the object "mLoads[0].mRequest"
mImage is null.

nsCOMPtr<imgIContainer> con;
mLoads[0].mRequest->GetImage(getter_AddRefs(con));
if (con) {

Does this have to do with caching? It happens on Windows also, changing
platforms to "All"
Assignee: rods → dcone
Keywords: nsbeta1
OS: Linux → All
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
When reflowing for leaving print preview this is null on the Initial reflow
also, then a dirty reflow causes it to layout correctly. 

So the question is, why isn't this image not there? 

Why isn't it in the cache?
Bulk moving all nsbeta1 nominations to future-P1. If they are approved
(nsbeta1+) they will be moved to mozilla1.0
Priority: -- → P1
Target Milestone: mozilla1.0 → Future
Reassigning to pavlov since the image is mysteriously disappearing from the cache.

Note: I have seen this happen with other images, not just the bugzilla image
attachmentments. If you print preview any image and change the scaling or change
it to landscape mode the image disappears. It does not reappear if you restore
the settings. You must reload the page.
Assignee: dcone → pavlov

Comment 5

17 years ago
Hmmm... wonder if this is related to the Heidi Klum bug. cc'ing darin/gordon here.

Comment 6

17 years ago
interesting, when i view just the image and i hit reload, it gets loaded twice!
 possibly related??
Is this still a problem?  This worksforme, but it also worksforme in a March
15th build....
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 9

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050905
Firefox/1.6a1 

please reopen with details if you find it fails
Assignee: pavlov → printing
QA Contact: sujay

Comment 10

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050905
Firefox/1.6a1 

please reopen with details if you find it fails
Status: NEW → RESOLVED
Last Resolved: 13 years ago
QA Contact: sujay
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.