Crash reading or writing email, via mozilla::gfx::SourceSurfaceCGBitmapContext::DrawTargetWillChange

RESOLVED WORKSFORME

Status

()

P3
critical
RESOLVED WORKSFORME
2 years ago
8 days ago

People

(Reporter: judith, Unassigned)

Tracking

({crash})

45 Branch
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tbird crash][gfx-noted], crash signature)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

Thunderbird has been open for a while and may also have been idle for a while. When I seek to open some mail it crashes.  I can not reproduce it.  My Thunderbird it up to date.  I have over 10,000 emails in it but was told Thunderbird does not have a problem with this size. It crashes at weird times. I do not recall how to create a log file to show the logs.  I installed an anti virus on the computer to make sure this was not the issue and there are no viruses. I have also run disk utility to clean up any bad files but also not an issues. Does anyone have any suggestions or can show me how to create a log file that I can post after the crash so people can read and let me know what it is. Thanks
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X

Comment 1

2 years ago
Please post your crash IDs here (in text format).
 see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
(Reporter)

Comment 2

2 years ago
I crashed again and then put my email address in the form and submitted it but then never got a Crash ID.  I can not seem to find it on my mac with the path you gave me. Is there any way to look it up by my email address which I submitted on the crash reporter.
(Reporter)

Comment 3

2 years ago
OK I have found an article on the web that told me how to get the IDs from Thunderbird so here they are
Report ID 	Submitted
bp-68d52b66-0f9c-421f-9e0d-d2d762160803	8/3/2016
bp-4db2b624-aa7a-4c63-952c-68a312160803	8/3/2016
bp-9dfb4091-21aa-4b83-9d79-424f62160803 8/3/2016
(Reporter)

Comment 4

2 years ago
Here are some other crash reports from last week
bp-b673171b-3c88-4e8e-bbb6-914612160729
	7/29/2016	1:33 PM
bp-818d0f60-f96a-4f34-9d1b-d2d302160727
	7/27/2016	1:05 PM

Comment 5

2 years ago
When did your crashes first start?
Any changes or updates made on your system around the time it started crashing?
Does crash go away if you have started thunderbird in safe mode?

bp-68d52b66-0f9c-421f-9e0d-d2d762160803  
 Ø 0 	libsystem_platform.dylib	libsystem_platform.dylib@0x53a7	
1 	XUL	mozilla::gfx::SourceSurfaceCGBitmapContext::DrawTargetWillChange()	gfx/2d/SourceSurfaceCG.cpp:352
2 	XUL	mozilla::gfx::SourceSurfaceCGBitmapContext::GetDataSurface()	gfx/2d/SourceSurfaceCG.h:135
3 	XUL	(anonymous namespace)::RectTextureImage::EndUpdate(bool)	widget/cocoa/nsChildView.mm:2980
4 	XUL	nsChildView::EndRemoteDrawing()	widget/cocoa/nsChildView.mm:2679
5 	XUL	mozilla::layers::BasicCompositor::EndFrame()	gfx/layers/basic/BasicCompositor.cpp:634
6 	XUL	mozilla::layers::LayerManagerComposite::Render(mozilla::gfx::IntRegionTyped<mozilla::gfx::UnknownUnits> const&)	gfx/layers/composite/LayerManagerComposite.cpp:844
7 	XUL	mozilla::layers::LayerManagerComposite::UpdateAndRender()	gfx/layers/composite/LayerManagerComposite.cpp:389
8 	XUL	mozilla::layers::LayerManagerComposite::EndTransaction(mozilla::TimeStamp const&, mozilla::layers::LayerManager::EndTransactionFlags)	gfx/layers/composite/LayerManagerComposite.cpp:316
9 	XUL	mozilla::layers::CompositorParent::CompositeToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const*)	gfx/layers/ipc/CompositorParent.cpp:1160
10 	XUL	mozilla::layers::CompositorVsyncScheduler::Composite(mozilla::TimeStamp)	gfx/layers/ipc/CompositorParent.cpp:559
Severity: normal → critical
Crash Signature: [@ libsystem_platform.dylib@0x53a7 ]
Keywords: crash
(Reporter)

Comment 6

2 years ago
Crashes started in June. Possibly I updated my system but do not recall. I will try it in Safe mode.  I do not have many add-ons just 2 of them and only one I use all the time.  It is Google Translate add on. I checked the add on and they are all up to date

Comment 7

2 years ago
FIrst crash on the system with your email address is bp-dbf3e0ac-a40e-48b6-ac54-305f72160609 from June 9
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Summary: Thunderbird keeps crashing although it is up to date. → Crash reading or writing email, via mozilla::gfx::SourceSurfaceCGBitmapContext::DrawTargetWillChange
(Reporter)

Comment 8

2 years ago
I have also checked my plug ins and only one is active and not updates available.  Did you notice anything unusual in the crash logs?

I also noticed that a few weeks ago Thunderbird was not sending certain mails. It seemed like they went and they got moved to sent mail, but no one received them.  In some tests, when I cc'd myself even I did not get them. I switched to another smtp server and the emails went but then also had a problem with that server.  But this was very intermittent and seems to have gone away, but it often happened a few hours before a crash of thunderbird. Not sure this is related at all. Also thought it might have been that I had not updated my thunderbird so did that but that did not seem to affect the crashes.  As I said they are very intermittent
(Reporter)

Comment 9

2 years ago
Here is one from June 2 and one from April 27
bp-27410ffd-44f5-461b-a3d9-f247c2160602
	6/2/2016	4:03 PM
bp-e41c33e9-6d60-4089-b7a4-f0cc32160427
	4/27/2016	2:21 AM

Comment 10

2 years ago
only bp-e41c33e9-6d60-4089-b7a4-f0cc32160427 is different - shutdownhang | libsystem_kernel.dylib@0x177ca 
and it is a somewhat old 38.5.1 - the only one you have cited that is not version 45.

> notice anything unusual in the crash logs?
no

also some firefox crashes like bp-81473b07-9bc4-4693-b476-13c082160615
(Reporter)

Comment 11

2 years ago
Yes but very few and that is because it gets hung up if I go to some sites. Also I have found that if I open too many windows on firefox it eats up too much bandwidth and so now I often close and restart Firefox if I get the spinning wheel.  Possibly my firefox problems have to do with interaction of HTTPs Everywhere, but I might be wrong or maybe it is the same problem. I have not idea. Should I post those crash logs as well?
(Reporter)

Comment 12

2 years ago
New Crash report, 1D9618A9-C295-480F-B6D2-732B301A4BC4
	8/4/2016	12:37 PM
(Reporter)

Comment 13

2 years ago
Three new crash reports
bp-49461c26-b28b-4416-b188-fd84b2160812	8/12/2016
bp-301ec7d6-eafc-4a28-b916-952352160810	8/10/2016
bp-42b5f0ac-f11d-41b4-9de7-8aae62160808 08/08/2016

Also Thunderbird has been a bit flaky lately. Sometimes it refuses to send an email claiming that the ISP drops in the middle or can not connect. No problems sending email with the same SMTP connection via my ipad. Also if start a new and copy and past the email into a new mail than it will work. Not really sure what is going on here
(Reporter)

Comment 14

2 years ago
Before I figured out how to get around this issue, I did try launching safe mode and still had the same problems with the email that could not be sent. It was only today that I figured out how to get the email to send. So possibly this is another bug but think it might be related to my current bug

Comment 15

2 years ago
Literally almost no Firefox crashes with this signaure
Component: General → Graphics
Product: Thunderbird → Core
Whiteboard: [tbird crash]
(Reporter)

Comment 16

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #15)
> Literally almost no Firefox crashes with this signaure

I am confused by this statement, can you please explain. thanks

Comment 17

2 years ago
that statement is for the graphics developers
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #15)
> Literally almost no Firefox crashes with this signaure

May have morphed into glvmSamplerLoadTexels crashes, now that we have symbols.  Still a very small number.
Whiteboard: [tbird crash] → [tbird crash][gfx-noted]
Hi Judith. Do you still crash when using a current version?
Flags: needinfo?(judith)
(Reporter)

Comment 20

8 days ago
No I have not had problems lately with the new version.
Flags: needinfo?(judith)
Excellent. Thanks for posting your update
Status: NEW → RESOLVED
Last Resolved: 8 days ago
Resolution: --- → WORKSFORME
also there are no crash reports in last month that contain glvmSamplerLoadTexels  in the signature
You need to log in before you can comment on or make changes to this bug.