DON'T USE WinXP debug only TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out - followed by numerous other update test failures on WinXP debug only

RESOLVED FIXED in Firefox -esr45

Status

()

Toolkit
Application Update
P3
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: Treeherder Bug Filer, Assigned: rstrong)

Tracking

({intermittent-failure})

unspecified
mozilla51
Unspecified
Windows XP
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox-esr45 fixed, firefox50 fixed, firefox51 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Comment 1

2 years ago
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* mozilla-central: 2
* autoland: 1

Platform breakdown:
* windowsxp: 6
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1291985&startday=2016-08-01&endday=2016-08-07&tree=all
Comment hidden (spam)

Comment 3

2 years ago
14 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 7
* fx-team: 4
* mozilla-inbound: 3

Platform breakdown:
* windowsxp: 14

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1291985&startday=2016-08-08&endday=2016-08-14&tree=all
OS: Unspecified → Windows XP
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out → Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out followed by numerous other update test failures
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out followed by numerous other update test failures → Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out - followed by numerous other update test failures on WinXP debug only
The isProcessRunning check always returns true for this failure and it appears that all of the tests that call isProcessRunning also fail when bootstrapSvc.js fails. This could be an intermittent bug in XP or a difference in the build systems when using the code in isProcessRunning and I'll try to find a more reliable way to accomplish what isProcessRunning accomplishes to fix this.
Created attachment 8783140 [details] [diff] [review]
patch - fix tests that run in parallel

Matt, I mistakenly added the isProcessRunning call to the parallel tests. It shouldn't be called for these tests since it runs in parallel and tests that run at the same time will give a false positive. This won't fix this bug entirely but it should make it so the parallel tests that fail in this instance succeed. It will also give me confirmation as to whether the call to isProcessRunning is returning a false positive for the sequential service tests.
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attachment #8783140 - Flags: review?(mhowell)
Keywords: leave-open
No longer depends on: 1287176
Attachment #8783140 - Flags: review?(mhowell) → review+

Comment 6

2 years ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d707b973192
Remove failing check from tests that run in parallel. r=mhowell
Created attachment 8784177 [details] [diff] [review]
patch rev1 - disable on XP debug

Matt, this appears to be specific to XP debug only so instead of spending time on trying to figure out why I'm opting to disable these tests on XP debug.
Attachment #8784177 - Flags: review?(mhowell)
This should just work but those are famous last words so here is a try push
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a321fce10e5
Comment on attachment 8784177 [details] [diff] [review]
patch rev1 - disable on XP debug

Looks like the build system is having issues. I'll push to try again soonish.
Attachment #8784177 - Flags: review?(mhowell)
Yep, bug 1297547 is making the builds fail
Since all of the tests specified didn't run I went ahead and pushed this to oak
https://treeherder.mozilla.org/#/jobs?repo=oak&revision=189f55e63199
Keywords: leave-open
Priority: -- → P3
Created attachment 8784542 [details] [diff] [review]
patch rev2 - disable on XP debug
Attachment #8784177 - Attachment is obsolete: true
Comment on attachment 8784542 [details] [diff] [review]
patch rev2 - disable on XP debug

I verified that the affected tests ran on all platforms except for Win XP debug so this should be good to go.
https://treeherder.mozilla.org/#/jobs?repo=oak&revision=189f55e63199&selectedJob=216459
Attachment #8784542 - Flags: review?(mhowell)
Comment on attachment 8784542 [details] [diff] [review]
patch rev2 - disable on XP debug

Review of attachment 8784542 [details] [diff] [review]:
-----------------------------------------------------------------

Most of the XP jobs are still pending (!), but xpcshell on opt and debug have passed, so I think we're good.
Attachment #8784542 - Flags: review?(mhowell) → review+

Comment 18

2 years ago
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9338a982d9ae
disable updater xpcshell tests on XP debug to prevent intermittent failures due to Process32FirstW failures on debug. r=mhowell
Pushed test only fix to mozilla-aurora
https://hg.mozilla.org/releases/mozilla-aurora/rev/458d5f0a55bb
status-firefox50: --- → fixed
Target Milestone: --- → mozilla51

Comment 20

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9338a982d9ae
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Duplicate of this bug: 1281586
Duplicate of this bug: 1273426

Comment 23

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 2
* mozilla-aurora: 2
* mozilla-inbound: 1
* autoland: 1

Platform breakdown:
* windowsxp: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1291985&startday=2016-08-22&endday=2016-08-28&tree=all
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out - followed by numerous other update test failures on WinXP debug only → DON'T USE WinXP debug only TEST-UNEXPECTED-TIMEOUT | toolkit/mozapps/update/tests/unit_service_updater/bootstrapSvc.js | Test timed out - followed by numerous other update test failures on WinXP debug only
You need to log in before you can comment on or make changes to this bug.