Closed Bug 1292002 Opened 5 years ago Closed 5 years ago

buttons on www.tripit.com don't work ("Go to mobile site", "Go to full site")

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1290823

People

(Reporter: dholbert, Unassigned)

Details

(Keywords: regression)

No description provided.
STR:
 0. (Don't be logged in to a TripIt account. We want the front page.)
 1. In Firefox Nightly on Android, visit https://www.tripit.com
 2. Click the "Go to mobile site" or "Go to full site" buttons.

EXPECTED RESULTS:
I should navigate to the site that I chose.

ACTUAL RESULTS:
Button changes to darker grey (showing that it's been tapped), but no navigation happens.

I get EXPECTED RESULTS in Firefox Aurora 49.0a2 from (2016-08-01)
I get ACTUAL RESULTS in Firefox Nightly 51.0a1 (2016-08-03)

Hence, this is a regression.

(In case it's confusing -- notice that there's currently a 2 version-number difference between Nightly and Aurora right now, because we just bumped the Nightly version number, but we haven't quite shipped Aurora50 yet.)
Summary: buttons on www.tripit.com don't work ("o to mobile site", "Go to full site") → buttons on www.tripit.com don't work ("Go to mobile site", "Go to full site")
FWIW, WebIDE shows that there are some JS errors when the page loads:
{
ReferenceError: it is not defined [Learn More]tripit.js:1:29294
TypeError: window.TRIPIT is undefined [Learn More]facebook.js:1:14
TypeError: window.TRIPIT is undefined [Learn More]placeholder.js:1:45
TypeError: window.TRIPIT is undefined [Learn More]creditCard.js:1:14
TypeError: window.TRIPIT is undefined [Learn More]creditCard.js:1:14
TypeError: window.TRIPIT is undefined [Learn More]tracking.js:1:14
TypeError: window.TRIPIT is undefined [Learn More]sessionUtil.js:1:14
}

BUT, I don't think those are related, because I see those same errors in Aurora as well (and navigation works correctly in Aurora)
I tried my STR in a Guest Session, too (with Nightly) and I got ACTUAL RESULTS there. So, I don't think this is caused by anything specific to my local profile.
Hardware-wise, this seems to be specific to Android hardware.
 - I reproduce on a Nexus 7 tablet and a OnePlus One phone.
 - I can *not* reproduce in Desktop Firefox Nightly 51, in responsive design mode with a Firefox-for-Android UA string. (Tested with & without the touch-event-emulation button)

That's why I've filed this (initially) as a Firefox-for-Android bug.
Thanks! Setting needinfo=me to see if this becomes fixed in the next Nightly or so (after bug 1290823's fix lands).
Flags: needinfo?(dholbert)
(Tentatively assuming this is a regression from bug 1250024 [which is in comment 5's range], like bug 1290823 is.)
Blocks: 1250024
I get EXPECTED RESULTS in latest Nightly, which suggests this was indeed fixed by (fixed) bug 1290823. Duping.
No longer blocks: 1250024
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 1290823
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.