In Nightly, Firefox Hello Beta opens tens of new windows upon clicking Hello's icon

RESOLVED FIXED

Status

Hello (Loop)
Client
--
major
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Fanolian, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160803030226

Steps to reproduce:

WARNING: Please test it in a throwaway profile.

1. In Nightly, install Firefox Hello Beta 1.4.3/1.4.4/1.5.0alpha201608040415 in a new profile.
2. Click the Hello icon.


Actual results:

1. The Hello icon is weirdly labelled as "loop-call-button3.label".
2. New windows are opened one by one rapidly which renders Nightly useless.
(Reporter)

Comment 1

a year ago
I mark the bug as major as it is a serious issue.

I tested Hello beta 1.4.4 on Firefox 48 (unofficial portable version) and it works properly. So I think this bug should not block bug 1291703 (Ship 1.4.4 of the Loop system add-on to the release population (via update mechanism)) for now.

I haven't tested this bug on 49 beta or 50 aurora yet.
Severity: normal → major
(Assignee)

Comment 2

a year ago
Fanolian, are you using the version of Hello from AMO? If so, I've just changed the max versions to be 48.* as Hello is being in 49 onwards, although I'm not sure that will limit it properly, so I might do something else for now.

We'll be putting out a version soon to AMO that removes itself from those versions.
Flags: needinfo?(Fanolian+bugzilla)
(Reporter)

Comment 3

a year ago
(In reply to Mark Banner (:standard8) from comment #2)
> Fanolian, are you using the version of Hello from AMO? 

Yes, from https://addons.mozilla.org/en-US/firefox/addon/firefox-hello-beta/versions/.

This bug is introduced by bug 1287827. Before bug 1287827, Hello beta 1.4.4 simply does not work, with some error messages in Browser Console, in recent Nightlies.

Bug 1287827 did not remove Hello Beta in my main profile and thus I encounter this bug. Perhaps I installed the extension myself long time ago before it became a system add-on, probably when it was first announced.

1 more questions:
Is Firefox Hello completely abandoned in 49 onwards, even not as a standalone extension in AMO? If so, it is fine not fixing this bug as long as we will have no ways to install Hello Beta, in 49+, unexpectedly.
Flags: needinfo?(Fanolian+bugzilla)

Comment 4

a year ago
There is same problem with Firefox 49.0b2 on Windows 8.1.
See https://youtu.be/42S-RKqYY3M
(Assignee)

Updated

a year ago
Duplicate of this bug: 1293934

Comment 6

a year ago
Created attachment 8781156 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/584
(Assignee)

Comment 7

a year ago
Comment on attachment 8781156 [details] [review]
Link to Github pull-request: https://github.com/mozilla/loop/pull/584

Simple change to not start Hello for FF 49 or later (i.e. no button nor anything else) - primarily just for posting to AMO for the beta add-on. We'll do an uninstall itself once we stop running Hello completely.
Attachment #8781156 - Attachment description: [loop] mozilla:remove-button-49 > mozilla:master → Link to Github pull-request: https://github.com/mozilla/loop/pull/584
Attachment #8781156 - Flags: review?(dpreston)
Attachment #8781156 - Flags: review?(dmose)
Attachment #8781156 - Flags: review?(dpreston) → review+
(Assignee)

Updated

a year ago
Attachment #8781156 - Flags: review?(dmose)
(Assignee)

Updated

a year ago
Assignee: nobody → standard8
(Assignee)

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

a year ago
We've now pushed a version to AMO that stops the add-on displaying the button or initialising in FF 49 or later. There will be a future update to make the add-on automatically uninstall itself.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.