Mozilla doesn't save files on disk

VERIFIED WONTFIX

Status

Core Graveyard
File Handling
--
blocker
VERIFIED WONTFIX
17 years ago
2 years ago

People

(Reporter: Max Alekseyev, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.9+) Gecko/20020305
BuildID:    2002030516

Mozilla asks for filename but doesn't save files on disk.
Neither "Save Page As...", nor "Enter name of file to save to..." dialogs isn't
followed by actual file writing.
Given URL is just an example. The bug doesn't depend on it.

Reproducible: Always
Steps to Reproduce:
1. Click on URL
2. Choose "Save this file to disk" and press "Ok"
3. Choose any filename & location
4. Press "Ok"


Actual Results:  Dialog is silenty closed. No file is saved.
Michael, are you seeing this too?  Max, this is working fine for me on Linux...
when did this problem first start for you?
(Reporter)

Comment 2

17 years ago
This problem arrived a couple of builds ago. I had been waited that it would be
fixed.
But it wasn't. So I reported it myself.
(Reporter)

Comment 3

17 years ago
The bug is disappeared after reboot.
Actually, I got weird bugs already several times, each time after updating Mozilla.
And they ussually disappear after reboot. I cann't find explaination for such
behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 4

17 years ago
Why is this WONTFIX? FileSaveAs actually works on HPFS, just not on FAT.

Comment 5

17 years ago
Felix, that's not the problem he's reporting.

Comment 6

17 years ago
He seems to be reporting that it never works. I wonder whether he has any HPFS
drives? WORKSFORME in HPFS. Does exactly as he reports on FAT16B.

Reporter, does the dialog disappear without a file save on both HPFS and FAT16B
drives?
Please read comment #3.  Then read the bug activity.  The bug is wontfix because
reporter marked it so  (worksforme would have been a better resolution).

Comment 8

16 years ago
verify wontfix
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.