Memory leak while running tstclnt on BoundsChecker - allocated by strdup in ssl3con.c

RESOLVED DUPLICATE of bug 133584

Status

NSS
Libraries
P2
minor
RESOLVED DUPLICATE of bug 133584
16 years ago
11 years ago

People

(Reporter: Bishakha Banerjee, Assigned: Julien Pierre)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Call stack as follows:

Memory leak
10 bytes allocated by strdup in ssl3con.c (4770), HANDLE: 0x01A50F00

Location of Error
ssl3_NewSessionID
ssl3con.c
4770
ssl3_HandleServerHello
ssl3con.c
4145
ssl3_HandleHandshakeMessage
ssl3con.c
7139
ssl3_HandleHandshake
ssl3con.c
7258
ssl3_HandleRecord
ssl3con.c
7523
ssl3_GatherCompleteHandshake
ssl3gthr.c
203
ssl_GatherRecord1stHandshake
sslcon.c
1256
ssl_Do1stHandshake
sslsecur.c
155
ssl_SecureSend
sslsecur.c
1036
ssl_SecureWrite
sslsecur.c
1070
ssl_Write
sslsock.c
1260
PR_Write
priometh.c
141
main
tstclnt.c
670
_mainCRTStartup
TSTCLNT.EXE!00007EFD
(unknown)

Comment 1

16 years ago
Nelson, do you know why we are leaking the 'urlSrvName' field of
a sslSessionID structure on the client side?  The only function
I can find that destroys sslSessionID is ssl_FreeSID, which
frees sid->urlSrvName (in ssl_DestroySID).  So I have no idea why
we are leaking this field.
Assignee: sonja.mirtitsch → wtc
Component: Test → Libraries
Priority: -- → P1
Target Milestone: --- → 3.4.1
Unless the program has been modified to flush the SSL client SID cache,
I suspect that all the SIDs in the client SID cache will appear to have
been "leaked" at the end of the program.  If the program only does one
https transaction, there will only be one SID that is leaked.  

If you want to clear the client SID cache, call SSL_ClearSessionCache(void)

Updated

16 years ago
Severity: normal → minor
Status: NEW → ASSIGNED
Priority: P1 → P2

Comment 3

16 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee

Comment 4

16 years ago
Set target milestone to NSS 3.5.
Target Milestone: 3.4.1 → 3.5

Updated

16 years ago
Target Milestone: 3.5 → 3.7

Comment 5

16 years ago
Moved to target milestone 3.8 because the original
NSS 3.7 release has been renamed 3.8.
Target Milestone: 3.7 → 3.8
Remove target milestone of 3.8, since these bugs didn't get into that release.
Target Milestone: 3.8 → ---
QA Contact: bishakhabanerjee → jason.m.reid
QA Contact: jason.m.reid → libraries
(Assignee)

Updated

11 years ago
Assignee: wtc → julien.pierre.boogz
Status: ASSIGNED → NEW
(Assignee)

Comment 7

11 years ago
This was fixed as part of bug 133584 . tstclnt was made to call SSL_ClearSessionCache() .
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 133584
You need to log in before you can comment on or make changes to this bug.