Intel HD3000 has no HWA on latest Nightly

RESOLVED DUPLICATE of bug 1292498

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1292498
a year ago
a year ago

People

(Reporter: Guilherme Lima, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
Something landed on the latest Nightly that is causing errors on my Intel HD3000. I suspect it's either bug 1289640 or bug 1284672.

about:support

Features
Compositing	Direct3D 9
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
WebGL2 Renderer	WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: WEBGL_NATIVE_GL_OLD_INTEL * Exhausted GL driver options.
Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
Audio Backend	wasapi
DirectWrite	false (6.2.9200.17568)
GPU #1
Active	Yes
Description	Intel(R) HD Graphics 3000
Vendor ID	0x8086
Device ID	0x0116
Driver Version	9.17.10.4229
Driver Date	5-26-2015
Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Subsys ID	00000000
RAM	Unknown
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
failures	[GFX1-]: VendorIDMismatch V 0x8086 0
Decision Log
DIRECT2D	
failed by runtime: Direct3D11 device does not support texture sharing
D3D11_HW_ANGLE	
broken by runtime: RenderTargetViews need recreating
Failure Log
(#0) Error	VendorIDMismatch V 0x8086 0
(#1) Error	[D3D11] create component blender failed: 0x80070057, 0
(#2) Error	[D3D11] create component blender failed: 0x80070057, 0
(#3) Error	[D3D11] create component blender failed: 0x80070057, 0
Which acceleration are you referring to? You're getting D3D9 layers.

What did about:support look like on the previous Nightly?
(Reporter)

Comment 2

a year ago
On Firefox 49b1 I get (I think it's exactly the same thing as previous Nightly, except for APZ):

Recursos
Composição	Direct3D 11
Deslocamento/Zoom assíncrono	nenhum
Renderização WebGL	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
Descodificação H264 por hardware	Yes; Using D3D9 API
Direct2D	true
DirectWrite	true (6.2.9200.17568)
GPU #1
Ativo	Sim
Descrição	Intel(R) HD Graphics 3000
ID do fornecedor	0x8086
ID do dispositivo	0x0116
Versão do driver	9.17.10.4229
Data do driver	5-26-2015
Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
ID do subsistema	00000000
RAM	Unknown
Diagnósticos
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
Whiteboard: [gfx-noted]
Let's duplicate this to bug #1292498 per regression range and more information,
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292498
You need to log in before you can comment on or make changes to this bug.