pdf.js causes the printer to produce one extra white page at the end of the printing job

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: jordan83, Unassigned)

Tracking

48 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160729072959

Steps to reproduce:

I printed a PDF file using pdf.js embedded in Mozilla Firefox



Actual results:

the printer produces the PDF and adds one extra white page at the end


Expected results:

The printer should not produce one white page at the end

I experienced this on several Firefox versions (I would say from version 38 to 48 for sure). I thought it was a printer problem until I got another one of another brand and stumbled upon this issue on GitHub: https://github.com/mozilla/pdf.js/issues/4041#issuecomment-237619349
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
User Agent: User Agent:  Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

I have tested your issue on latest Firefox release (v48.0) and latest Nightly (v51.0a1, Build ID: 20160808030441) and could not reproduce it. I have opened different PDF documents and printed them (from 1 to 5 pages). At the end of printing there were no blank pages. All pages were accounted for. I've also tried with the Development Version of PDF.js (http://mozilla.github.io/pdf.js/extensions/firefox/pdf.js.xpi) and there was no blank page at the end of printing.

Is this still reproducible on your end ? If yes, can you please retest this using latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(jordan83)
Marking this as Resolved-WFM due to the lack of response from the reporter.

If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jordan83)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.