Closed Bug 1292340 Opened 4 years ago Closed 4 years ago

Firefox Sync: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended

Categories

(Firefox :: Sync, defect)

49 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: wtds.trabalho, Assigned: markh)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160803080609

Steps to reproduce:

After instabilities I see this problem in terminal.
The problem is direct related to Firefox Sync, for example when see Firefox sync pages.

 


Actual results:

Instabilities.

from terminal:
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended



Expected results:

Understand the source of problem.
Solve instabilities.

Thanks.
I see the console warning, on beta and nightly (2016-08-08), after logging into Firefox Sync (or Firefox Account), with clean profile.

Can you describe the detail about "instabilities" ?
Status: UNCONFIRMED → NEW
QA Whiteboard: [bugday-20160808]
Component: Untriaged → Sync
Ever confirmed: true
Flags: needinfo?(wtds.trabalho)
It looks like this warning was added in bug 667233, and I guess comes from https://dxr.mozilla.org/mozilla-central/rev/e78975b53563d80c99ebfbdf8a9fbf6b829a8a48/services/sync/modules/engines/passwords.js#150, where Sync is searching by GUID.

Matt, do you think it's reasonable to only log those warnings |if (!matchData.hasKey("guid"))|?
Blocks: 667233
Flags: needinfo?(wtds.trabalho) → needinfo?(MattN+bmo)
(In reply to Tooru Fujisawa [:arai] from comment #1)
> I see the console warning, on beta and nightly (2016-08-08), after logging
> into Firefox Sync (or Firefox Account), with clean profile.
> 
> Can you describe the detail about "instabilities" ?

Freeze browser and interact non responsive. I can reproduce after enabled sync at clean profile. 
The browse unresponsive is hard to use. Because after browser syncing start the browser only unlock after 60 seconds. Sorry my poor English. If you need more info please contact me. 

Thanks. 

From: Mark 
" Matt, do you think it's reasonable to only log those warnings |if (!matchData.hasKey("guid"))|?"
(In reply to Wellington Torrejais da Silva from comment #3)
> Freeze browser and interact non responsive. I can reproduce after enabled
> sync at clean profile. 
> The browse unresponsive is hard to use. Because after browser syncing start
> the browser only unlock after 60 seconds. Sorry my poor English. If you need
> more info please contact me. 

That seems unrelated to the warnings you reported. Could you please follow the instructions at https://wiki.mozilla.org/CloudServices/Sync/File_a_desktop_bug (including the step for enabling logOnSuccess=true) and upload the logs you get to a new bug?
(In reply to Mark Hammond [:markh] from comment #2)
> It looks like this warning was added in bug 667233, and I guess comes from
> https://dxr.mozilla.org/mozilla-central/rev/
> e78975b53563d80c99ebfbdf8a9fbf6b829a8a48/services/sync/modules/engines/
> passwords.js#150, where Sync is searching by GUID.
> 
> Matt, do you think it's reasonable to only log those warnings |if
> (!matchData.hasKey("guid"))|?

Yep, totally.
Flags: needinfo?(MattN+bmo)
Assignee: nobody → markh
Comment on attachment 8779178 [details]
Bug 1292340 - Don't issue login manager warnings about recommended search criteria when a guid is specified.

https://reviewboard.mozilla.org/r/70220/#review67500
Attachment #8779178 - Flags: review?(MattN+bmo) → review+
Pushed by mhammond@skippinet.com.au:
https://hg.mozilla.org/integration/autoland/rev/9c4c621a9565
Don't issue login manager warnings about recommended search criteria when a guid is specified. r=MattN
https://hg.mozilla.org/mozilla-central/rev/9c4c621a9565
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
You need to log in before you can comment on or make changes to this bug.