Closed Bug 129236 Opened 21 years ago Closed 21 years ago

stops sending after first non iso-8859-1 character

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 117422

People

(Reporter: skd, Assigned: alexsavulov)

Details

(version 0.9.8)

HTML page has:
<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-2">
it also contains form with text area. If there is any non iso-8859-1 character
it is not sended neither any data after it.

example:
form method GET
text area named "test"
text typed into this: www eeeXsjdXdga shgdX
  (X's are polish characters)
the URL that is called by mozilla after submit contains only: test=www+eee

If there was no META in the page, all data were sent good (polish chars were
translated to %XX).
I use buid 2002030508 on win2000 and I am not able to reproduce the bug. However
I think it could be a dup of bug 117422, which was fixed a few days ago.
Indeed it is working in nightly.

*** This bug has been marked as a duplicate of 117422 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
verifying
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.