Setting the review state after editing the review header starts inserting exciting markup in my header

RESOLVED DUPLICATE of bug 1283024

Status

MozReview
Review Board: User Interface
RESOLVED DUPLICATE of bug 1283024
2 years ago
2 years ago

People

(Reporter: bz, Unassigned)

Tracking

Details

STEPS TO REPRODUCE:

1)  Start off with a review that was requested from me.
2)  Type some per-line review commets.
3)  Click the "Finish..." button.
4)  Edit the header to say "foo".  Click "OK" on that part.
5)  Change the "Review state" dropdown from "r?" to "r-".
6)  Click "OK" on the header edit field that popped up.
7)  Change the "Review state" dropdown from "r-" to "r?".
8)  Click "OK" on the header edit field that popped up.
9)  Change the "Review state" dropdown from "r?" to "r-".
10) Click "OK" on the header edit field that popped up.

EXPECTED RESULTS: At all steps after step 4, the header text says "foo"

ACTUAL RESULTS: After step 5, the header shows a textarea again, and the text says "<p>foo</p>".  After step 7 the textarea says "<p>&lt;p&gt;foo&lt;/p&gt;</p>".  After step 8, it says "<p>&lt;p&gt;&amp;lt;p&amp;gt;foo&amp;lt;/p&amp;gt;&lt;/p&gt;</p>".

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283024
You need to log in before you can comment on or make changes to this bug.