If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ajplus.co.uk - layout is off to right

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
English Other
--
major
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: jg, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [havefix ?] DUPEME, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020227
BuildID:    2002022700

layout is off to right

Reproducible: Always
Steps to Reproduce:
1.to go site
2.
3.

Actual Results:  layout is off to right

Comment 1

16 years ago
Confirmed
2002030208/WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
UK site -> West Europe
I've seen this problem on other sites too, bug 99289?
Assignee: momoi → nitot
Component: English: Non-US → Europe: West
QA Contact: jonrubin → brantgurganus2001
Summary: layout is off to right → ajplus.co.uk - layout is off to right
Whiteboard: DUPEME

Comment 3

15 years ago
If you remove the loading of the stylesheet from the page then the site displays
correctly, running the stylesheet through the W3C CSS Validator gives:
Line: 184 Context : .prod
Parse Error - prod_headings { COLOR: #000000; FONT-FAMILY: Arial, Helvetica,
Geneva, Swiss, SunSans-Regular; FONT-SIZE: 16px; TEXT-DECORATION: none }

By a process of elimination the part of the CSS that seems to cause the problem
is the following:
.leftbanners
{
    TEXT-ALIGN: center;
    WIDTH: 140px
}

Any ideas why?
OS: Linux → All
might be related : they are using underscore in class names, which is forbidden.
quote from the CSS recommandation
(http://www.w3.org/TR/REC-CSS2/syndata.html#value-def-identifier) :

#  In CSS2, identifiers  (including element names, classes, and IDs in
selectors) can contain only the characters [A-Za-z0-9] and ISO 10646 characters
161 and higher, plus the hyphen (-); they cannot start with a hyphen or a digit.
They can also contain escaped characters and any ISO 10646 character as a
numeric code (see next item). For instance, the identifier "B&W?" may be written
as "B\&W\?" or "B\26 W\3F".

there is an errata on this that allows this but this shouldnt be done anyway :
http://devedge.netscape.com/viewsource/2001/css-underscores/
Whiteboard: DUPEME → [havefix ?] DUPEME
Works for me, build 2002122208
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 6

15 years ago
VERIFIED WORKSFORME 2002122208
Status: RESOLVED → VERIFIED

Comment 7

15 years ago
tech evang june 2003 reorg
Component: Europe: West → English Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.