incorrect character coding detection

VERIFIED DUPLICATE of bug 115114

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 115114
17 years ago
17 years ago

People

(Reporter: Daniel Pavel, Assigned: Shanjian Li)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020302
BuildID:    2002030208

Character coding is detected as Central European (ISO-8859-2), but the page is
Western (ISO-8859-1).  Happents on a very large number of pages with Western
character coding.

This bug is present on all builds I've used since at least 0.97 (can't remember
before that), both stable and nightly.

Reproducible: Always
Steps to Reproduce:
Just load an affected page.


Actual Results:  The page was rendered using ISO-8859-2 character coding (the
View / Character Coding menu shows ISO-8859-2 as selected).  Some characters
("-","'") are displayed as a white question mark in a black diamond.

Expected Results:  Should have detected ISO-88590-1 as the Character Coding
(when I change it to this value in the View/Character Coding menu, the page is
displayed correctly).

Guess I should note that the system's (win2k) locale is set to English (US),
with the language settings accepting Central European and Western (the latter
being the default).  In Mozilla, the default Character Coding is Western also,
with "English/US [en-us]" and "English [en]" as accepted languages.  The
View/Character Coding/Auto-Detect option is set to "Universal".

Comment 1

17 years ago
please try to pick a component based on the components descriptions page (click 
components when filing your bug...)
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: doronr → ruixu

Comment 2

17 years ago
I can reproduce the bug with build 2002030508 on win2000.
Steps to reproduce
1. Set View/Character Coding/Auto-Detect option to "Universal"
2. Go to http://firingsquad.gamers.com/hardware/langearpreview/page2.asp
3. Look View/Character Coding, it is set to ISO-8859-2

With View/Character Coding/Auto-Detect option set to "(Off)", the page is
treated as ISO-8859-1 (my default coding I guess)

Comment 3

17 years ago
Netscape 6.2 (build 20011019) displays the page as
"Windows-1252" with Auto-Detect ALL; but
when I use mozilla (2002-03-01) with Auto-Detect Universal,
the page is displayed as "ISO-8859-2".
Assignee: yokoyama → shanjian
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 115114 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 5

17 years ago
Mark as verified as dup. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.