Closed Bug 1292465 Opened 5 years ago Closed 5 years ago

Bump firefox-puppeteer 51.0.0 and release to pypi

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set
normal

Tracking

(firefox51 fixed)

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

Details

Attachments

(1 file)

Now that Firefox reached version 51.0 on mozilla-central we should bump the version of Firefox Puppeteer accordingly to line-up.
Marking as leave-open so I can push to PyPI before the bug gets closed.
Keywords: leave-open
Summary: Bump firefox-puppeteer to version 51.0 → Bump firefox-puppeteer 51.0.0 and release to pypi
Comment on attachment 8778179 [details]
Bug 1292465 - Bump firefox-puppeteer to 51.0.0.

https://reviewboard.mozilla.org/r/69534/#review66848
Attachment #8778179 - Flags: review?(dburns) → review+
Comment on attachment 8778179 [details]
Bug 1292465 - Bump firefox-puppeteer to 51.0.0.

https://reviewboard.mozilla.org/r/69534/#review67160

::: testing/puppeteer/firefox/requirements.txt:1
(Diff revision 2)
> -marionette-driver >= 1.4.0
> +marionette-driver >= 2.0.0

I rebased my initial patch for the changes as made on bug 1292394. To match marionette-driver versions I also bumped the dep for puppeteer.
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0dd75eb09dc
Bump firefox-puppeteer to 51.0.0. r=automatedtester
Upload to pypi is done:

Uploading distributions to https://pypi.python.org/pypi
Uploading firefox_puppeteer-51.0.0-py2-none-any.whl
Uploading firefox-puppeteer-51.0.0.tar.gz
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.