[e10s] New tab position on middle click not always on right to the tab the link was opened in

RESOLVED DUPLICATE of bug 1248768

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1248768
2 years ago
2 years ago

People

(Reporter: antti.boman, Unassigned)

Tracking

({polish})

48 Branch
x86_64
Linux
polish
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728203720

Steps to reproduce:

1. Open a page with many links
2. Open loads of tabs by middle-clicking
3. Go to one of the tabs already loaded
4. Middle-click any link, and quickly select another tab



Actual results:

The link opens on the right of the newly selected tab, not the tab the link was clicked in.


Expected results:

The link should have opened on the right of the the tab the link was clicked in.

This happens only if the browser cannot open the new tab instantly.

This bug is _not_ reported using the profile that has e10s activated. The computer, browser version and (most) add-ons, however, are the same.

The profile in question has the booleans "browser.tabs.remote.force-enable" and "browser.tabs.remote.autostart" set as "true".

about:support / Multiprocess Windows: 1/1 (Enabled by user)
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
tracking-e10s: --- → ?

Updated

2 years ago
Status: UNCONFIRMED → NEW
QA Whiteboard: [bugday-20160808]
Component: Untriaged → Tabbed Browser
Ever confirmed: true

Updated

2 years ago
tracking-e10s: ? → +
Keywords: polish
Priority: P3 → P4

Updated

2 years ago
Priority: P4 → P3

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248768
You need to log in before you can comment on or make changes to this bug.