Bookmark bar context menu is disabled

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: jkt, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8778246 [details]
Selection_260.png

I'm not sure if step 1. is required.

STR:
1. Drag the identity of a site (the i icon in the url bar) to the bookmark bar
2. Right click
3. All the menu is disabled
(Reporter)

Comment 1

a year ago
I was unable to reproduce after a restart, will update if I can reproduce again.

Comment 2

a year ago
I think I'm having the same issue: All items in the context menu for bookmarks in the bookmarks toolbar are grayed out, and can't be clicked. I notice it's only this way for the bookmarks toolbar; the context menu works as it should on bookmarks in the side bar and in the Library window.

The context menu isn't *always* disabled, but I haven't been able to figure out what causes the problem. The context menu will be broken for several hours at a time. Restarting the browser doesn't always help.

I'm currently using Firefox Developer Edition 51.0a2, which automatically updates itself with the latest daily patches. Let me know if you can think of specific things I should test, or any debugging settings I should enable.

Comment 3

a year ago
Actually over the past few days, the context menu has been *permanently* disabled for the bookmarks toolbar. I've never been able to try to reproduce the bug, because I've never been able to make it stop.

Comment 4

a year ago
...Note that I'm only experiencing this in Firefox Developer Edition (which automatically updates itself with latest daily patches). The context menu for the bookmarks toolbar in Firefox stable works as it should.

Comment 5

a year ago
I finally remembered to try launching Firefox in Safe Mode. On Firefox Developer Edition, I'm also trying out the experimental addons in the Test Pilot program. I was able to narrow it down to the Tabs Center extension -- the context menu in the bookmarks toolbar gets disabled as soon as I turn on Tabs Center, and the context menu works as it should again when I disable this extension and restart Firefox.

Jonathan, this may not have been the same problem as what you had after all. I could start a new bug report or whatever you think is best.
please report the problem to tab center.

I actually think also the original bug was due to an add-on.
Not a firefox bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Comment 7

a year ago
Looks like someone has already reported it to Tabs Center.

https://github.com/bwinton/TabCenter/issues/706
You need to log in before you can comment on or make changes to this bug.