Closed Bug 1292558 Opened 3 years ago Closed 3 years ago

Artifact builds failing during configure on Windows: old-configure: line 5561: cc: command not found

Categories

(Firefox Build System :: General, defect, major)

defect
Not set
major

Tracking

(firefox51 fixed)

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: aryx, Assigned: cmanchester)

References

Details

(Keywords: regression)

Attachments

(1 file)

Artifact build with mozilla-central's tip d320ef56876f fails for jkt and me:

 0:17.72 creating cache ./config.cache
 0:18.62 checking host system type... i686-pc-mingw32
 0:19.13 checking target system type... i686-pc-mingw32
 0:19.66 checking build system type... i686-pc-mingw32
 0:20.09 configure: error: compiler is incompatible with sanitize options
 0:20.10 DEBUG: This file contains any messages produced by compilers while
 0:20.10 DEBUG: running configure, to aid debugging if configure makes a mistake.
 0:20.10 DEBUG:
 0:20.10 DEBUG: configure:969: checking host system type
 0:20.10 DEBUG: configure:990: checking target system type
 0:20.10 DEBUG: configure:1008: checking build system type
 0:20.10 DEBUG: configure:5562: cc -o conftest    conftest.c  1>&5
 0:20.10 DEBUG: c:/Mozilla/Coding/Code/mozilla-central/old-configure: line 5561: cc: command not found
 0:20.10 DEBUG: configure: failed program was:
 0:20.10 DEBUG: #line 5555 "configure"
 0:20.10 DEBUG: #include "confdefs.h"
 0:20.10 DEBUG:
 0:20.10 DEBUG: int main() {
 0:20.10 DEBUG:
 0:20.10 DEBUG: ; return 0; }
 0:20.10 DEBUG: configure: error: compiler is incompatible with sanitize options
 0:20.10 ERROR: old-configure failed
 0:20.13 *** Fix above errors and then restart with\
 0:20.13                "c:/Mozilla/Coding/Buildtools/MozillaBuild/mozmake/mozmake.EXE -f client.mk build"
We were hitting the CC=cl fallback before, but we shouldn't be doing these checks at all during artifact builds.
Assignee: nobody → cmanchester
Blocks: 1292059
Attachment #8778355 - Flags: review?(mh+mozilla) → review?(mshal)
Comment on attachment 8778355 [details]
Bug 1292558 - Skip sanitizer option detection when doing an artifact build.

https://reviewboard.mozilla.org/r/69662/#review66758
Attachment #8778355 - Flags: review?(mshal) → review+
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e902e21e9b3
Skip sanitizer option detection when doing an artifact build. r=mshal
https://hg.mozilla.org/mozilla-central/rev/6e902e21e9b3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.