Crash in ss2osd.dll@0x6699

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
critical
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Larry, Unassigned)

Tracking

({crash})

48 Branch
x86
Windows 10
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-b307157b-d1e0-4726-b949-b62b42160805.
=============================================================

Comment 1

2 years ago
Same issue in the recent past: bug 1262348.
Is it a (new?) variant of ss2osd.dll to block?
Component: General → Audio/Video
Flags: needinfo?(jmuizelaar)
Keywords: crash
Product: Firefox → Core
Version: unspecified → 48 Branch

Updated

2 years ago
Duplicate of this bug: 1293678
I realize it's not really Graphics since Jeff handled the last instance of this DLL busting us, but there is no 'good' component that I know of for DLL blocking (maybe XPCOM because it's startup?)  In any case, it's not core:audio/video.
Component: Audio/Video → Graphics
Whiteboard: [gfx-noted]
These are Flash plugin crashes, which had temporarily busted between 2016-05-17 and 2016-07-21/2016-07-29, with bug 1285356 fixing the problem (in 50, uplifted to 49).  However, there are recent crashes in 49 beta; for example - https://crash-stats.mozilla.com/report/index/de3e3ad9-5e1d-4214-adad-794852160822.  I don't know how to tell if that's because Flash is in "protected mode child process" or because bug 1285356 regressed.
Flags: needinfo?(jmuizelaar) → needinfo?(aklotz)
Component: Graphics → Plug-ins

Comment 5

2 years ago
This is one of the Flash processes that they use with protected mode. Our DLL blocklist does not (and will not) apply to those processes, so I'm just going to WONTFIX this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aklotz)
Resolution: --- → WONTFIX
(Reporter)

Comment 6

2 years ago
May I ask what this means?  Is work being done with this still?

Comment 7

2 years ago
No, Mozilla is not working on this. This is a crash in a combination of two pieces of 3rd-party software (Adobe Flash and some ASUS software), and so Firefox cannot fix it. If you are still experiencing this crash, you will need to uninstall one of those, or file a bug with one of those two vendors: Adobe is unlikely to be able to fix this, so filing an issue with ASUS support is my recommendation.
You need to log in before you can comment on or make changes to this bug.