/home/product/Fennec returns a 400 error

REOPENED
Unassigned

Status

Socorro
General
P3
normal
REOPENED
a year ago
20 days ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8778301 [details]
qa - screenshot of 400 error

I thought Fennec had aged out of the system. It's back in the product drop-down and returns a HTTP 400 error from the API.

https://crash-stats.mozilla.com/home/product/Fennec
https://crash-stats.allizom.org/home/product/Fennec
Oh noes. I suspect it's a matter of this: https://github.com/mozilla/socorro/pull/3413

I'll dig into it.
I remember looking at crash-stats.m.c last week and there was just a 'FennecAndroid' in the Product dropdown, which still appears to work. Now there's a 'Fennec' as well, which makes a funny ADI request with desktop platforms, eg

https://crash-stats.mozilla.com/api/ADI/?product=Fennec&platforms=Windows&platforms=Mac OS X&platforms=Linux&start_date=2016-07-31&end_date=2016-08-07
Assignee: nobody → peterbe
I ran this on the stage DB:

breakpad=> update product_versions set sunset_date = '2016-08-08' where product_name = 'Fennec' and sunset_date > now();
UPDATE 7
Update; now I ran:

breakpad=> update product_versions set sunset_date = '2016-08-07' where product_name = 'Fennec' and sunset_date >= '2016-08-08';
UPDATE 7
(Reporter)

Comment 5

a year ago
Stage is looking good. Let's ship-it to prod.
Run on prod::

 breakpad=> update product_versions set sunset_date = '2016-08-07' where product_name = 'Fennec' and sunset_date >= '2016-08-08';
UPDATE 7

(Gotto wait for caching)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 7

a year ago
Verified on prod. Thanks!
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

a year ago
Reopening. Fennec appears as a product option on stage and prod again. FTP scraper at work again?

https://crash-stats.mozilla.com/home/product/Fennec
https://crash-stats.allizom.org/home/product/Fennec
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 9

3 months ago
@peterbe -- Fennec is a product again in stage and prod. Did something add new versions?
Flags: needinfo?(peterbe)
Sure enough. They keep coming back.
https://crash-stats.mozilla.com/api/ProductVersions/?active=true&product=Fennec
Grr
Flags: needinfo?(peterbe)
I'm unable to crack this. I don't know update_product_versions.sql manages to create product versions from releases_raw when the product_name is "mobile".

Note-to-self; Once we figure it out we need to do similar manual changes afterwards.
Assignee: peterbe → nobody
Fennec still appears in the list of products, however it's no longer returning an HTTP 400 error. There's an e2e test that's marked as expected to fail due to this bug: https://github.com/mozilla-services/socorro/blob/fa09a97432b42aca2fccf78a61b4aead2f43f078/e2e-tests/tests/test_crash_reports.py#L35-L39
So, I have two thoughts on this:

1. It's tricky to figure out what's going on given that this bug has been around for a year and was fixed and then reopened.

2. Unless I'm missing something, the impact of this on Firefox 57 and other important activities is like 0.

Given that, I'm marking this as a P3. I don't know when someone will get to this. We should adjust any tests that are failing out or whatever accordingly if they haven't already been adjusted.

Having said that, the test linked to in comment #12 appears to be making sure products are sorted correctly. Given that we have like 4 products, maybe we don't care about that at all and we should delete the test.

Is there something compelling about testing whether products are sorted correctly?
Priority: -- → P3
> We should adjust any tests that are failing out or whatever accordingly if they haven't already been adjusted.

The test is already marked as expected to fail, so there's not really any action there until the issue is resolved. I've been going through tests that are xfailed today and checking if they're still accurately marked.

> Having said that, the test linked to in comment #12 appears to be making sure products are sorted correctly. Given that we have like 4 products, maybe we don't care about that at all and we should delete the test.

The test would fail if the products were in the wrong order, but it would also fail if the list of products changed in any other way, such as a product missing from the list, or an extraneous product. That said, we wouldn't currently detect this kind of failure because of this issue and the fact the test is marked as expected to fail.

In my opinion, this isn't a very useful test as it is, and I'd be happy to submit a pull request to remove or update it based on your feedback.
davehunt: A PR to remove the test is fine and would be appreciated.
> A PR to remove the test is fine and would be appreciated.

Opened https://github.com/mozilla-services/socorro/pull/4025

Comment 17

20 days ago
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/6781a0d761a6d11dcd3ba3203c5f8f91ab437827
Bug 1292594 - Remove test_that_products_are_sorted_correctly (#4025)

After some discussion it has been decided that this test is not providing enough value, especially as it has been marked as expected to fail for at least six months.
You need to log in before you can comment on or make changes to this bug.