If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Yahoo! one-off search is executed after pressing tab, even after pressing down-arrow key to select a different URL suggestion

RESOLVED INVALID

Status

()

Firefox
Address Bar
P3
normal
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 affected)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

a year ago
STR:
1. Enter some text into the address bar.
2. Press the Tab key.
3. The Yahoo! one-off search button will be selected instead of the first URL suggestion. (See bug 1292321 for discussion of this UX change.)
4. Oops. That's not what I wanted, so press the down-arrow key to select a URL suggestion from the drop-down list.
5. Press the Enter key to select the highlighted URL suggestion.

RESULT:
Instead of opening the highlighted URL suggestion, the Yahoo! one-off search is executed instead.
After pressing tab once, the down arrow should move the selection to the next one-off button (that's what happens in the searchbar). The strange behavior here seems to be a consequence of the double selection in the awesomebar (bug 1292630).
After bug 1292321 this should not happen anymore, right?
Component: Search → Location Bar
Priority: -- → P3
Whiteboard: [fxsearch]
Chris, do you still see this?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 4

a year ago
This bug is no longer reproducible because the new address bar behavior was disabled in bug 1292321.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(cpeterson)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.