Mac updater will update Firefox to an incompatible version

RESOLVED DUPLICATE of bug 1293707

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 1293707
2 years ago
2 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

Trunk
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox48 affected)

Details

(Reporter)

Description

2 years ago
I just got a bug report from my mother. She has an older Mac running 10.7.5. Her previous version of Firefox (not sure what) updated in the background to one that requires Mac OS 10.9. Her running Firefox crashed, and now she can't use Firefox, because it won't launch on 10.7.5.

This does not seem like correct behavior of the updater!
(Reporter)

Comment 1

2 years ago
Deduction says that it just updated to 48, presumably from 47. I just sent her an FTP link to Firefox 47.0.1 to get her unblocked.
(Reporter)

Updated

2 years ago
status-firefox48: --- → affected
status-firefox51: affected → ---

Comment 2

2 years ago
Hi Richard, I tested this issue on Mac Os X 10.7 and I can't reproduce it. 
Here is what I tried:

Install a Firefox 47 version and then updated to 48.0.1, everything worked as expected. I also restarted the browser and no issue appeared. 
There are no chances that this issue to be related with the profile or some add-ons?

Maybe you can give us more details about this issue to try to reproduce it.
(Reporter)

Comment 3

2 years ago
I wonder if she's on Beta? 48 is supposed to be the last supported Old Mac release.

The only other relevant detail is that she's on a very old Mac; 4+ years old.

The post-update attempts to run were met with the usual Mac version error, along the lines of "this application doesn't run on this version of Mac OS".

Comment 4

2 years ago
I will NI? Stephen, maybe he knows more about this issue, and he can tell us what to look for.

Stephen can you take a look at this bug and tell me if you know something about this issue and how can I help you with further investigations. Thanks
Component: Untriaged → Application Update
Flags: needinfo?(spohl.mozilla.bugs)
Product: Firefox → Toolkit
What we need to see is the update url that is used. This is how the servers figure out if Firefox is compatible with the OS and if not the server doesn't advertise an update.

To get the update url in about:config change app.update.log to true and then check for updates in the about dialog. Then open the browser console and look for an entry that starts with:
AUS:SVC Checker:getUpdateURL - update URL: 

Copy and paste that line into the bug.
Flags: needinfo?(spohl.mozilla.bugs) → needinfo?(bhearsum)
Ben, when did the Mac rules go into place on Beta and Aurora?
This looks like a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1293707. The bad update was live from whenever Firefox 49.0 first shipped to Beta (looks like August 3rd) until August 9th.
Flags: needinfo?(bhearsum) → needinfo?(rail)
Bug 1293707 sounds like the most plausible cause here. The timings also align.
Flags: needinfo?(rail)
(Reporter)

Comment 9

2 years ago
That's enough for me. Thanks, folks! Wanted to make sure that it didn't go unreported.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293707
You need to log in before you can comment on or make changes to this bug.