Closed Bug 1292786 Opened 3 years ago Closed 3 years ago

Intermittent dom/canvas/test/test_capture.html | application crashed [@ mozilla::dom::HTMLCanvasElement::SetFrameCapture(already_AddRefed<mozilla::gfx::SourceSurface>)]

Categories

(Core :: Canvas: 2D, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: pehrsons)

References

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted])

Attachments

(1 file)

Crash dereferencing a null pointer to a surface in SetFrameCapture, because the CopySurface call in WillRefresh returned null. I am not familiar with this code so I'm not sure if the WillRefresh is responsible for not producing null pointers or if we should handle this gracefully lower down the stack, or something else.
Andreas, any idea?
Flags: needinfo?(pehrson)
Whiteboard: [gfx-noted]
I think we should just avoid calling SetFrameCapture() when CopySurface() returns nullptr.

I'll get to it in a bit.
Assignee: nobody → pehrson
Flags: needinfo?(pehrson)
Status: NEW → ASSIGNED
Comment on attachment 8781993 [details]
Bug 1292786 - Don't SetFrameCapture() when CopySurface() fails.

https://reviewboard.mozilla.org/r/72292/#review69884
Attachment #8781993 - Flags: review?(nical.bugzilla) → review+
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/828e9a557da4
Don't SetFrameCapture() when CopySurface() fails. r=nical
https://hg.mozilla.org/mozilla-central/rev/828e9a557da4
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Duplicate of this bug: 1324815
You need to log in before you can comment on or make changes to this bug.