Closed Bug 1293028 Opened 3 years ago Closed 3 years ago

Newer Intel graphics drivers blocked for webgl2, inaccurate version detection

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox50 --- fixed
firefox51 --- fixed

People

(Reporter: aryx, Assigned: ethlin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Firefox 51.0a1 20160805030444 and 50.0a2 20160805004022 on Windows 8.1 64 bit, i7-4700MQ processor (Intel HD 4600)

about:support lists:
> WebGL2 Renderer	WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: WEBGL_NATIVE_GL_OLD_INTEL * Exhausted GL driver options.

That's https://hg.mozilla.org/mozilla-central/rev/7b0427fcc6aa#l1.89 from bug 1268638.

The drivers for the processor can be found at https://downloadcenter.intel.com/de/product/75117/Intel-Core-i7-4700MQ-Processor-6M-Cache-up-to-3-40-GHz-

I have the newest version for Windows 8.1 installed (15.36.31.4414) which was made available in May (13.05.2016).

About support lists it as
> Driver Version	10.18.14.4414

No idea what the first three numbers represent. Maybe just compare the last number (build ID?)?
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] from comment #0)
> Firefox 51.0a1 20160805030444 and 50.0a2 20160805004022 on Windows 8.1 64
> bit, i7-4700MQ processor (Intel HD 4600)
> 
> about:support lists:
> > WebGL2 Renderer	WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: WEBGL_NATIVE_GL_OLD_INTEL * Exhausted GL driver options.
> 
> That's https://hg.mozilla.org/mozilla-central/rev/7b0427fcc6aa#l1.89 from
> bug 1268638.
> 
> The drivers for the processor can be found at
> https://downloadcenter.intel.com/de/product/75117/Intel-Core-i7-4700MQ-
> Processor-6M-Cache-up-to-3-40-GHz-
> 
> I have the newest version for Windows 8.1 installed (15.36.31.4414) which
> was made available in May (13.05.2016).
> 
> About support lists it as
> > Driver Version	10.18.14.4414
> 
> No idea what the first three numbers represent. Maybe just compare the last
> number (build ID?)?

I think we should just compare the last number. The web page explains the number meaning: http://www.intel.com/content/www/us/en/support/graphics-drivers/000005654.html

The first two numbers are about platform version and DirectX version. The third number seems a reserved column. I'll have a patch for it.
Assignee: nobody → ethlin
Attached patch check build idSplinter Review
Instead of checking the whole version, I checked build id only for intel driver on windows.
Attachment #8778818 - Flags: review?(mtseng)
Comment on attachment 8778818 [details] [diff] [review]
check build id

Jeff has better knowledge than me here. Pass review to him.
Attachment #8778818 - Flags: review?(mtseng) → review?(jmuizelaar)
This issue should be uplifted to aurora after resolving.
Comment on attachment 8778818 [details] [diff] [review]
check build id

Review of attachment 8778818 [details] [diff] [review]:
-----------------------------------------------------------------

The version detection non-withstanding, I'd double check if we want to allow non-Windows 10 here.
Attachment #8778818 - Flags: review?(jmuizelaar) → review?(jgilbert)
Attachment #8778818 - Flags: review?(jgilbert) → review+
Duplicate of this bug: 1294094
FYI If you want to see how driver versions map to driver dates, OS and other telemetry points this page is a good way to do that (It will take a long time to load):
https://people.mozilla.org/~danderson/moz-gfx-telemetry/www/#view=hwpivot
Keywords: checkin-needed
Comment on attachment 8778818 [details] [diff] [review]
check build id

Approval Request Comment
[Feature/regressing bug #]: 1268638
[User impact if declined]: Some users cannot run WebGL properly
[Describe test coverage new/current, TreeHerder]: test on locally and tryserver
[Risks and why]: low risk
[String/UUID change made/needed]: none
Attachment #8778818 - Flags: approval-mozilla-aurora?
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e9d724ab066e
Check build id only for intel driver. r=mtseng, r=jgilbert
Keywords: checkin-needed
Hi Wes, is this one stuck on inbound? I happened to notice it while reviewing Aurora uplift requests.
Flags: needinfo?(wkocher)
https://hg.mozilla.org/mozilla-central/rev/e9d724ab066e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Keywords: regression
Comment on attachment 8778818 [details] [diff] [review]
check build id

Fixes a regression in our whitelisting logic, Aurora50+
Attachment #8778818 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.