Gtk stock icon disabled states are broken

RESOLVED WONTFIX

Status

()

P3
major
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: dao, Unassigned)

Tracking

({regression, regressionwindow-wanted})

48 Branch
Unspecified
Linux
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
E.g. moz-icon://stock/gtk-go-back-ltr?size=toolbar&state=disabled

I'm on Ubuntu 16.04. I don't know if this is our regression or theirs, but I suspect the former; I'd be surprised if this was broken in all Gtk applications.
(Reporter)

Updated

2 years ago
Summary: Gtk stock icons disabled states are broken → Gtk stock icon disabled states are broken

Comment 1

2 years ago
I can reproduce the problem on Ubuntu16.04LTS, but not on Ubuntu14.04LTS.


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1ee54e043b9b&tochange=939320b957c5

Triggered by: 939320b957c5	Mike Hommey — Bug 1186003 - Switch automated builds to Gtk+3. r=mshal
WFM with GTK+ 3.18.9 default theme (Adwaita), but not Ambiance.

Seems to be what the theme is requesting because I get the same behavior with gtk3-demo:

1. Click twisty by Icon View.
2. Double click Icon View Basics.
3. Repeatedly click up button until at root directory.

With Adwaita, the up icon and text become more grey.
With Ambiance, only the text becomes more grey.

I don't know whether this is a bug or intended behavior from Ambiance, but Gecko is matching the system behavior correctly.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Priority: -- → P3
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.