scale value of 100 should be reset after you exit and relaunch

RESOLVED DUPLICATE of bug 118563

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 118563
16 years ago
12 years ago

People

(Reporter: sujay, Assigned: Samir Gehani)

Tracking

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: test page setup also after this is fixed.)

(Reporter)

Description

16 years ago
using 3/6 trunk build on win 989

1) launch netscape
2) jump to any page
3) Print Preview
4) change the zoom/scale value from 100 to anything(use the buttons, because
   of the other bug which crashes when you enter in scale field)
5) Close on PP panel, exit Netscape
6) Relaunch netscape
7) go back into Print Preview 

notice the zoom/scale value is not reset to 100, shouldn't it be ?
do we want to remember the old value for successive launch of netscape?
(Assignee)

Comment 1

16 years ago
We need to think through persistence of settings.  As of now, the page setup
dialog doesn't use the global settings (which is controlled by a pref) but the
print preview toolbar code always uses the global settings.  Maybe the fix here
is to use local settings (and include code to change to global settings based on
the pref like the page setup dialog does).  Finally, we could expose this pref
as a ``Remeber these values'' on the page setup dialog.  This is a collection of
ideas based on a discussion with Bill.  
Target Milestone: --- → mozilla1.2
(Reporter)

Comment 2

16 years ago
I presume fixing this bug will also fix the problem where scale value
doesn't reset to 100 in the Page Setup dialog also. just a reminder
for me to test...
Whiteboard: test page setup also after this is fixed.

Comment 3

15 years ago
YES YES YES I totally want it to remember the settings under Page Setup. 
E-mails print way to big at 100%.
(This is Moz 1.4 RC 3 and it's still doing this.)

Note that in other Windows applications these settings ARE persistent.
Maybe, this bug is same bug 18563.
Please check on latest builds.

*** This bug has been marked as a duplicate of 118563 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.