Scratchpad PrettyPrint formatting issue with class declaration

RESOLVED DUPLICATE of bug 951622

Status

()

Firefox
Developer Tools: Scratchpad
P2
normal
RESOLVED DUPLICATE of bug 951622
a year ago
a day ago

People

(Reporter: Himanshu Pathak, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160803081036

Steps to reproduce:

--------> In Scratchpad, I added code for some class declaration : 

class someClass {

}

--------> And clicked on PrettyPrint, the autoformatting concatenated class with someClass 


Actual results:

classsomeClass{
}



Expected results:

class someClass{
}
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160810030202

I have tested your issue on Ubuntu 14.04 with latest Firefox release (v48.0) and latest Nightly (v51.a1) and managed to reproduce it. I have inserted the code provided, in comment 0, in Scratchpad and after clicking the "PrettyPrint" button, the issue was observable.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Scratchpad
Ever confirmed: true
Scratchpad triage. Filter on TRIAGE-JD201705

Similar to 1302058, we should look into using the prettifier from the debugger.
Priority: -- → P2
Another pretty-printer problem. We should fix all of them at once by upgrading the pretty-printer we use.
Status: NEW → RESOLVED
Last Resolved: a day ago
Resolution: --- → DUPLICATE
Duplicate of bug: 951622
You need to log in before you can comment on or make changes to this bug.