Support VS2015 in set-msvc-env.sh and drop old versions

RESOLVED DUPLICATE of bug 1293190

Status

RESOLVED DUPLICATE of bug 1293190
2 years ago
2 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8778781 [details] [diff] [review]
vs201315.patch

set-msvc-env.sh contains old VS versions and miss new Visual Studio Releases like 14 (Visual Studio 2015).

Since Firefox 48 and later build with Visual Studio 2015 in our official releases we should also support this.

Added a patch also cleans up old versions
Attachment #8778781 - Flags: review?(bob)
(Reporter)

Comment 1

2 years ago
Created attachment 8778782 [details] [diff] [review]
vs201315-1.patch
Attachment #8778781 - Attachment is obsolete: true
Attachment #8778781 - Flags: review?(bob)
Attachment #8778782 - Flags: review?(bob)

Comment 2

2 years ago
Comment on attachment 8778782 [details] [diff] [review]
vs201315-1.patch

Review of attachment 8778782 [details] [diff] [review]:
-----------------------------------------------------------------

We don't want to lose the ability to build old versions, so we'll need to keep them available.

::: bin/set-msvc-env.sh
@@ -8,5 @@
>          ;;
>  esac
>  
>  export MSVCROOTKEY="$HKLM_SOFTWARE/Microsoft/VisualStudio"
> -export MSVC10KEY="$MSVCROOTKEY/10.0/Setup/VC"

keep this as it is an officially supported compiler for Firefox 14-36.

@@ -9,5 @@
>  esac
>  
>  export MSVCROOTKEY="$HKLM_SOFTWARE/Microsoft/VisualStudio"
> -export MSVC10KEY="$MSVCROOTKEY/10.0/Setup/VC"
> -export MSVC11KEY="$MSVCROOTKEY/11.0/Setup/VC"

We can drop this since it wasn't an officially supported compiler.

@@ -14,5 @@
>  export MSVC12KEY="$MSVCROOTKEY/12.0/Setup/VC"
> -
> -if [[ -z "$VC10DIR" ]]; then
> -    export VC10DIR=`regtool get "$MSVC10KEY/ProductDir" 2> /dev/null`
> -fi

Keep this.

@@ -18,5 @@
> -fi
> -
> -if [[ -z "$VC11DIR" ]]; then
> -    export VC11DIR=`regtool get "$MSVC11KEY/ProductDir" 2> /dev/null`
> -fi

Ok to drop this.

@@ +24,5 @@
>  USE_MSVC_VER=$(grep USE_MSVC_VER $MOZCONFIG|sed 's|USE_MSVC_VER=\(.*\)|\1|')
>  
>  if [[ -z "$USE_MSVC_VER" ]]; then
>  
> +    # The official compiler for Firefox 48 and later is VC 14.

# The official compilers
# Firefox 14-36 VC10 Visual Studio 2010
# Firefox 37-47 VC12 Visual Studio 2013
# Firefox 48+   VC14 Visual Studio 2015

@@ +29,5 @@
>  
>      if [[ -n "$VC12DIR" ]]; then
>          USE_MSVC_VER=2013
> +    elif [[ -n "$VC14DIR" ]]; then
> +        USE_MSVC_VER=2015

Move this to the first test in the if..elif..

@@ -34,5 @@
>  
>      if [[ -n "$VC12DIR" ]]; then
>          USE_MSVC_VER=2013
> -    elif [[ -n "$VC11DIR" ]]; then
> -        USE_MSVC_VER=2012

Ok to drop this.

@@ -41,3 @@
>      else
>          error "Unsupported compiler version"
>      fi

The order here was important. The most recent default version was tested first, followed by the older versions.
Attachment #8778782 - Flags: review?(bob) → review-

Comment 3

2 years ago
duping to bug 1293190
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293190
You need to log in before you can comment on or make changes to this bug.