support for mozilla-build 2.x versions

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cbook, Assigned: bc)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8778787 [details] [diff] [review]
mozillabuild2.patch

mozilla-build 2.x change the way scripts are called and this result in the default configuration a stalled bughunter worker.

To fix this we must change the start-shell script as example for vs2015 as attached
Attachment #8778787 - Flags: review?(bob)
(Assignee)

Comment 1

2 years ago
Comment on attachment 8778787 [details] [diff] [review]
mozillabuild2.patch

I've not been happy with duplicating the mozilla build batch files.
Attachment #8778787 - Flags: review?(bob)
(Assignee)

Comment 2

2 years ago
Created attachment 8799459 [details] [diff] [review]
bug-1293190-msvc-2015.patch

This fixes this bug and also bug 1293187. It bundles some additional changes along with it:

adds -X to the help message for builder.sh

changes the DEBUG environment variable to SISYPHUS_SCRIPT_DEBUG since DEBUG by itself conflicted with Django DEBUG and other possible uses.

adds a kill_mozilla_build function to library.sh and calls it when terminating. This helps resolve the cases where a Ctrl-C would terminate the script but leave the msys + msvc processes running.

fixes an issue where the 64bit architecture wasn't detected properly leading to 32bit builds on 64bit windows.

in set-build-env.sh, unset SCRIPT environment variable in addition to the bash functions which causes problems with msys and configure.

The meat of the patch is in set-msvc-env.sh. I left the MSVC11 stuff in case we can find an 2012 compiler.

If we have USE_MSVC_VER less than 2013, then we will use an older copy of Mozilla Build located in c:\mozilla-build.old. Otherwise we use the default location in c:\mozilla-build. This allows us to continue to use older mozilla builds for really old compilers if we can find them.

Depending on whether we are using a newer Mozilla Build or an older one, we patch the appropriate batch files and create the msys-command versions for cygwin to use.

Note I changed the recommendation on paths and now recommend using /etc/fstab in msys to map /mozilla to c:\cygwin\mozilla. This elimiates the indirection of symbolic links.

I've tested this on Windows 7 32bit and 64bit (though 32bit runs out of memory) and have tested -X intel32 on Windows 7 64bit to build 32bit binaries. I haven't let the builds run to completion since my qemu vms would take ages to complete.

Sorry it took me so long to look into this and in rewriting it.
Attachment #8778787 - Attachment is obsolete: true
Attachment #8799459 - Flags: review?(cbook)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1293187
(Reporter)

Comment 4

2 years ago
Comment on attachment 8799459 [details] [diff] [review]
bug-1293190-msvc-2015.patch

looks good, thanks!
(Reporter)

Updated

2 years ago
Attachment #8799459 - Flags: review?(cbook) → review+
(Assignee)

Comment 5

2 years ago
http://hg.mozilla.org/automation/sisyphus/rev/8b718376964e
http://hg.mozilla.org/automation/sisyphus/rev/4d72ae19cf9a
Assignee: nobody → bob
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.