Multiple problems with Firefox including checking for plugins update, connecting to firefox support

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: anindakumars, Unassigned)

Tracking

48 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

1. click on Tools -> Add Ons
2. click on 'Check to see if your plugins are up to date'
3. See what happened #1
4. click on 'Need Help? Visit Mozilla Support' link


Actual results:

1. This page opens with a spinning wheel that keeps on spinning and don't show any results. 
https://www.mozilla.org/en-US/plugincheck/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=plugincheck-update

2. (related to step #4) Shows problem loading page at the title (url is https://support.mozilla.org/products/firefox/manage-preferences-and-add-ons-firefox/install-and-manage-add-ons) and shows 'Secure Connection Failed' with the following message.
"The connection to the server was reset while the page was loading.

 The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."


Expected results:

For step #3 - plugins should have been listed showing any plugin that is outdated

For step 4, the webpage should have opened.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

I have tested your issue on Windows 7, Win 8.1 and Win 10 with latest Firefox release (v48.0) and could not reproduce it. After clicking on "Check to see if your plugins are up to date" link, a new tab is opened in which I am informed of the status of the plugins. The page is loaded correctly. This issue sounds more like a configuration or something related to the cache. Maybe this article will be of assistance: https://support.mozilla.org/en-US/questions/1024256

Is this still reproducible on your end ? If yes, can you please retest this using latest Firefox release and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Flags: needinfo?(anindakumars)
(Reporter)

Comment 2

2 years ago
I cannot reproduce it at home either :(.I started in safe mode, but even then the problem persists.

I am wondering if this is some setting within my corporate network that is causing the problem. I had a friend in IT helpdesk try to connect to this website, and I guess support.mozilla.org is being blocked by our DNS server. I think you can't help me here, I will have to figure that out.
Based on Comment 2 from the reporter, changing status to RESOLVED-WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(anindakumars)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.