System font setting respected by location bar but ignored by location bar's autocomplete drop-down list

VERIFIED FIXED in Firefox 49

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: icuin2me, Assigned: adw)

Tracking

(Depends on: 1 bug, {regression})

48 Branch
Firefox 51
x86_64
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 verified, firefox50 verified, firefox51 verified)

Details

(Whiteboard: [fxsearch])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
str
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728203720

Steps to reproduce:

STEP 1: Open terminal and issue the following command,
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
Observation 1: Urlbar font size is small.
Observation 2: Urlbar popup/drop-down font size is small.

STEP 2: Open terminal and issue the following command,
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 20'
Observation 1: Urlbar font size is big.
Observation 2: Urlbar popup/drop-down font size is small. (THIS IS THE ISSUE)




Actual results:

When system font size was increased from 10 to 20, urlbar font size increased but urlbar autocomplete drop-down list font size did not increase.


Expected results:

When system font size was increased from 10 to 20, urlbar font size increased and urlbar drop-down list font size should also have increased just as it used to be in previous versions of Firefox.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Component: Untriaged → Location Bar
(Reporter)

Updated

2 years ago
Summary: System font setting respected by urlbar but ignored by urlbar's autocomplete drop-down list → System font setting respected by location bar but ignored by location bar's autocomplete drop-down list
This might be because .ac-title and .ac-url have font-sizes defined in terms of px.  Before the redesign, .ac-comment and .ac-url-text had em font-sizes.

This may affect people with impaired vision, and the fix should be simple, and we should uplift it, so we should probably look into this soon.
Priority: -- → P1
Whiteboard: [fxsearch]
Blocks: 1181078
Duplicate of this bug: 1292920
I haven't tested this yet myself, but confirming since there was a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → adw
Status: NEW → ASSIGNED
Keywords: regression
Comment hidden (mozreview-request)
This goes back to using the em sizes we used before the redesign: https://hg.mozilla.org/mozilla-central/diff/061165ac1ff9/browser/themes/linux/browser.css

It retains the size difference between titles and URLs from the new design but also correctly resizes when doing the STR in comment 0.

Comment 6

2 years ago
mozreview-review
Comment on attachment 8784657 [details]
Bug 1293308 - System font setting respected by location bar but ignored by location bar's autocomplete drop-down list.

https://reviewboard.mozilla.org/r/74008/#review72404

This is fine for Linux.
What about Windows? We were using em on Windows too before the change, and while I think it's not possible anymore to change the font in 8, 8.1 and 10, it is still possible in Windows 7, that we support. What do you think?
Attachment #8784657 - Flags: review?(mak77) → review+
Ah OK, I tried changing the system font size on 10 and couldn't figure out how to do it.  I'll try on 7 then.
Interestingly the current Nightly works on Windows 7 already, even with the px units.  There are three options for font size that I can find: in Control Panel > Appearance and Personalization > Display.  And the popup text is adjusted based on the size I pick.  So I'll land this as is.

Comment 9

2 years ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f32e2e8eb298
System font setting respected by location bar but ignored by location bar's autocomplete drop-down list. r=mak

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f32e2e8eb298
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Comment on attachment 8784657 [details]
Bug 1293308 - System font setting respected by location bar but ignored by location bar's autocomplete drop-down list.

Approval Request Comment
[Feature/regressing bug #]: New urlbar popup design, bug 1181078
[User impact if declined]: Linux users who have non-default system font sizes will see incorrect font size in urlbar popup (e.g., users with accessibility needs)
[Describe test coverage new/current, TreeHerder]: Manual testing
[Risks and why]: Low risk, a small CSS-only Linux-only change
[String/UUID change made/needed]: None
Attachment #8784657 - Flags: approval-mozilla-beta?
Attachment #8784657 - Flags: approval-mozilla-aurora?
status-firefox49: --- → affected
status-firefox50: --- → affected
Hello Ajay, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(icuin2me)
Comment on attachment 8784657 [details]
Bug 1293308 - System font setting respected by location bar but ignored by location bar's autocomplete drop-down list.

CSS only, low-risk, Aurora50+
Attachment #8784657 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 14

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/ca2340129749
status-firefox50: affected → fixed
Comment on attachment 8784657 [details]
Bug 1293308 - System font setting respected by location bar but ignored by location bar's autocomplete drop-down list.

This patch fixes a UI issue of autocomplete drop-down list in location bar. Take it in 49 beta.
Attachment #8784657 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

2 years ago
Depends on: 1299777

Comment 16

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/58ec38e8bfd6
status-firefox49: affected → fixed
Flags: qe-verify+
Verified as fixed with Firefox 49 beta 9, latest Aurora 50.0a2 2016-09-02 and latest Nightly 51.0a2 2016-09-01 under Ubuntu 16.04 64-bit.
Status: RESOLVED → VERIFIED
status-firefox49: fixed → verified
status-firefox50: fixed → verified
status-firefox51: fixed → verified
Flags: qe-verify+
Flags: needinfo?(icuin2me)
You need to log in before you can comment on or make changes to this bug.