tabs.remove callback called before tab is removed

RESOLVED DUPLICATE of bug 1291830

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1291830
a year ago
a year ago

People

(Reporter: robwu, Assigned: robwu)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

a year ago
My change to bug 1288901 caused the following test failure:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4ce8fad27a47&selectedJob=24999434
207 INFO TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_getViews.js | tab count correct - Got 2, expected 1

This is because the callback for tabs.remove (http://searchfox.org/mozilla-central/rev/5b35b60ada19621c84ecab78998416d8b86a8254/browser/components/extensions/test/browser/browser_ext_getViews.js#59) is called before the tab is removed.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291830
Comment hidden (mozreview-request)
Comment on attachment 8779112 [details]
Bug 1293485 - wait until tab is gone before calling callback of tabs.remove

https://reviewboard.mozilla.org/r/70154/#review67434
Attachment #8779112 - Flags: review?(kmaglione+bmo) → review-
(Assignee)

Updated

a year ago
Attachment #8779112 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.