Publish is dimmed out after Edit page from server and Save

VERIFIED DUPLICATE of bug 134311

Status

--
trivial
VERIFIED DUPLICATE of bug 134311
17 years ago
14 years ago

People

(Reporter: sujay, Assigned: cmanske)

Tracking

Trunk
mozilla1.1alpha

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
using 3/6 build

1) launch netscape
2) edit any page on any web server
3) Save As, give it a file name
4) exit composer
5) launch composer again
6) open that file you just saved

notice that at this point, Publish is dimmed out. It shouldn't
be.
(Assignee)

Comment 1

17 years ago
The Save button is also disabled, right? The Save and Publish commands both
reflect the modified state of the document. So you should use "Publish As" to 
publish a local file. If the "Publish" item was enabled, that is the action it
would take anyway.
I suppose we could make an exception and keep "Publish" enabled all the time for
local documents. 
Kathy?

Comment 2

17 years ago
If Publish is going to be enabled when editing a local file (which could be
reasonable), then Save should also be enabled when editing a remote file.

I think this is fine but we shouldn't worry about it for this milestone.
(Assignee)

Comment 3

17 years ago
Save isn't available when editing a remote file :)
(Assignee)

Comment 4

17 years ago
I wonder if we should hide the "Publish" menuitem when editing a local file!

Comment 5

17 years ago
No, I don't think the Publish menu item should just disappear.  Just like I
don't think the Save menu item should just disappear if you are editing a remote
page.

I am happy with the current behavior for mozilla 1.0.  I think Sujay is also ok
with it.

Post 1.0, I think we should consider enabling them and making them do their "as"
counterparts.
Severity: normal → trivial
Target Milestone: --- → mozilla1.1
(Assignee)

Comment 6

17 years ago
This issue is now addressed in bug 134311. I am restoring the "Publish" menuitem
when editing local files and it will always be enable when editing local files.


*** This bug has been marked as a duplicate of 134311 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.