browser.urlbar.unifiedcomplete is not longer working

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: aaltruista, Unassigned)

Tracking

({ux-control})

48 Branch
ux-control
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8779296 [details]
ebay.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160806094113

Steps to reproduce:

Updated to Firefox 48


Actual results:

browser.urlbar.unifiedcomplete used to hide "Visit domain.com" in search bar suggestion. Now it shows "Visit domain.com" which is useless.

For years I got used to type:

E - down arrow - enter = to visit my ebay sold items. it shows ebay now
G - down arrow - enter = to visit gmail. it shows google now
SA - down arrrow - enter = to visit sales manager. it shows ebay sandbox now.
RO - down arrow - enter  = to visit royal mail despatch managaer. it show royal mail main website now

I didn't even had to think about it. 

and mady many more. search bar is super annoying now.




Expected results:

browser.urlbar.unifiedcomplete should disable "Visit domain.com"
(Reporter)

Updated

2 years ago
Keywords: ux-control
OS: Unspecified → All
Hardware: Unspecified → All
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (48.0) and managed to reproduce it.
After visiting a link multiple times for example http://www.ebay.co.uk/rpp/electronics, when typing the first leter "e", Visit "ebay.co.uk" shows first in search bar suggestion.
This also happens when browser.urlbar.unifiedcomplete is set to false.

Also, I will assign a component and  maybe someone with more experience regarding this issue could provide some feedback.

See also: bug 1236265.
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
this is by design, since maintaining the option had an high cost.
We have bugs filed to implement users feedback already, like bug 1235397. You can search for other issues, I'm sure most/all of them are filed already and tracked by bug 1262507.

Note that, since the new Action Row is preselected, your "down arrow" action end up exactly in the same place as before, thus your muscle-memory actions are not affected.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
also, browser.urlbar.unifiedcomplete is a dead pref, and as such you can remove it completely.
You need to log in before you can comment on or make changes to this bug.