Searching from context menu switches to new tab even though "When I open a link in a new tab, switch to it immediately" is unchecked

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
2 years ago
2 months ago

People

(Reporter: Jason, Unassigned)

Tracking

(Blocks: 1 bug)

47 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606113944

Steps to reproduce:

(Similar but not identical to bug 691114)
In Preferences, ensure "When I open a link in a new tab, switch to it immediately" is unchecked.
Open a web page that contains some text.
Highlight a word.
Right click on the highlighted word and choose 'Search <search provider> for "word".



Actual results:

Firefox switches to the tab with the word search results. 


Expected results:

Firefox should open the new tab in the background.
(Reporter)

Updated

2 years ago
See Also: → bug 691114
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

I have tested this issue on Windows 10 x64, Mac OS 10.10 and Ubuntu 14.04 x64 with the latest Firefox release (48.0) and the latest Nightly (51.0a1-20160811030201) and managed to reproduce it.
After following the STR in the description, when right clicking on the highlighted word and choosing 'Search <search provider> for "word"', Firefox switches to the tab with the word search results.
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Based on this being fixed in bug 331222 before this is a regression. Emil, can you try figuring out when it regressed?
Flags: needinfo?(emil.pasca)
I've ran a regression and came up with the following pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e79245e249c4&tochange=1fa31fa85082
After taking a look at this pushlog I think that bug 695482 may had cause it, further more, it seems that it may had been a decision that this was in fact the intended behavior.
What should we do next?
Flags: needinfo?(emil.pasca) → needinfo?(gijskruitbosch+bugs)
Yes, this is apparently behaving as designed. If you want search to also open in the background, you can change the browser.search.context.loadInBackground pref in about:config.
Blocks: 727131, 695482
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → WONTFIX

Updated

a year ago
Blocks: 1327284
Duplicate of this bug: 1420099
You need to log in before you can comment on or make changes to this bug.