Closed Bug 1293638 Opened 3 years ago Closed 3 years ago

ctrl+t doesn't work when Arabic is selected

Categories

(Core :: Widget: Win32, defect)

48 Branch
All
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox48 --- wontfix
firefox49 + wontfix
firefox-esr45 --- unaffected
firefox50 + fixed
firefox51 + fixed

People

(Reporter: bugzy, Assigned: masayuki)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

Using Windows.
Selecting Arabic language for keyboard input.
Pressing ctrl+t


Actual results:

The shortcut didn't work; a new tab wasn't opened.


Expected results:

It should've opened a new tab.
Component: Untriaged → Keyboard Navigation
Duplicate of this bug: 1296607
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regression range:

Last good revision: 5e14887312d4523ab59c3f6c6c94a679cf42b496 (2016-03-15)
First bad revision: 341344bdec8f10bf50646cd6ef2355361435cbf6 (2016-03-16)
 
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5e14887312d4523ab59c3f6c6c94a679cf42b496&tochange=341344bdec8f10bf50646cd6ef2355361435cbf6
(In reply to Kanchan Kumari QA from comment #2)
> Regression range:
> 
> Last good revision: 5e14887312d4523ab59c3f6c6c94a679cf42b496 (2016-03-15)
> First bad revision: 341344bdec8f10bf50646cd6ef2355361435cbf6 (2016-03-16)
>  
> Pushlog:
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=5e14887312d4523ab59c3f6c6c94a679cf42b496&tochange=3413
> 44bdec8f10bf50646cd6ef2355361435cbf6

Probably regressed by one of Masayuki's patches?
Flags: needinfo?(masayuki)
[Tracking Requested - why for this release]: Regression of bug 1137561 and the fix will be simple and having automated test.

Okay, this is a simple regression of bug 1137561. We failed to set alternative charcode values to keydown event on Ctrl+T for Arabic keyboard layout because Shift+T inputs 2 characters but NativeKey::WillDispatchKeyboardEvent() waits 2nd keydown event for setting alternative charcode to "t". (But of course, keydown is fired only once.)
Assignee: nobody → masayuki
Blocks: 1137561
Status: NEW → ASSIGNED
Component: Keyboard Navigation → Widget: Win32
Flags: needinfo?(masayuki)
OS: Unspecified → Windows
Product: Firefox → Core
Hardware: Unspecified → All
Ah, this is also a regression of bug 1203059.
Blocks: 1203059
Tracking 51+ for this regression affecting the Arabic language.
Comment on attachment 8787099 [details]
Bug 1293638 NativeKey::WillDispatchKeyboardEvent() should set alternative charCode values properly when other shift state inputs longer text

https://reviewboard.mozilla.org/r/75970/#review74686
Attachment #8787099 - Flags: review?(m_kato) → review+
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/74e63f4ecc6c
NativeKey::WillDispatchKeyboardEvent() should set alternative charCode values properly when other shift state inputs longer text r=m_kato
https://hg.mozilla.org/mozilla-central/rev/74e63f4ecc6c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Comment on attachment 8787099 [details]
Bug 1293638 NativeKey::WillDispatchKeyboardEvent() should set alternative charCode values properly when other shift state inputs longer text

Approval Request Comment
[Feature/regressing bug #]: Bug 1203059 and bug 1137561.
[User impact if declined]: Arabic users cannot use Ctrl+T (and some other shortcut keys if the key with different shift state causes inputting longer text)
[Describe test coverage new/current, TreeHerder]: Landed on m-c and adding an automated test.
[Risks and why]: Low because the fix is simple but it's hard to explain with short lines. Please see comment 6 or commit message of this patch for the detail of the regression reason.
[String/UUID change made/needed]: Nothing.
Attachment #8787099 - Flags: approval-mozilla-aurora?
Hello bugzy, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(bugzy)
Comment on attachment 8787099 [details]
Bug 1293638 NativeKey::WillDispatchKeyboardEvent() should set alternative charCode values properly when other shift state inputs longer text

Fixes a recent regression, patch has a new automated test (yay!), Aurora50+.
Attachment #8787099 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Track 49+/50+ as this is a regression.
Flags: needinfo?(bugzy)
You need to log in before you can comment on or make changes to this bug.