If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox 49.0 Beta update offered to OS X 10.6

VERIFIED FIXED

Status

Release Engineering
Releases
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: lmandel, Assigned: Callek)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Seems our watershed configuration is not correct. My brothers OS X 10.6.8 laptop was automatically updated to Firefox 49.0 Beta (don't know which Beta). After restarting he was presented with an OS X dialog informing him that the software was not support on his version of the OS.

I think the expectation should be that no update is offered in any form to users on OS X 10.6-10.8.
Flags: needinfo?(andrei.vaida)
As I understand it, Ben has already fixed this issue. 

Andrei - Do you have OS X 10.6-10.8 installed so that you can test that the update from Firefox 48 Beta to 49 Beta does not occur?
(Assignee)

Comment 2

a year ago
self assigning while we validate this is indeed fixed, since I'm on releaseduty.
Assignee: nobody → bugspam.Callek
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #1)
> As I understand it, Ben has already fixed this issue. 
> 
> Andrei - Do you have OS X 10.6-10.8 installed so that you can test that the
> update from Firefox 48 Beta to 49 Beta does not occur?

I can confirm that this is fixed on Mac OS X 10.6.8, Mac OS X 10.7.5
and Mac OS X 10.8.5.

Here's a breakdown:
  - Mac OS X 10.6.8
      - 48.0b2-build2 and 48.0b7-build1 were updated to 48.0 via beta
      channel
      - no other updates were found on the channel after browser
      restart
      - "You can not perform further updates on this system" message
      is displayed in About Firefox

  - Mac OS X 10.7.5
      - 48.0b9-build1 was updated to 48.0 via beta channel
      - no other updates were found on the channel after browser
      restart
      -  "You can not perform further updates on this system" message
      is displayed in About Firefox
      
  - Mac OS X 10.8.5
      - 47.0b4-build1 and 48.0b6-build1 were updated to 48.0 via beta
      channel
      - no other updates were found on the channel after browser
      restart
      - "You can not perform further updates on this system" message
      is displayed in About Firefox
Flags: needinfo?(andrei.vaida)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1292667
You need to log in before you can comment on or make changes to this bug.