Moving the cursor with the arrow keys in textfields leaves junk

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: mjudge)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
See the URL for an example.  In this example,
I entered the text:

  "note the junk left by the cursor"

and moved the cursor back a few words using the
arrow keys.

Comment 1

17 years ago
always include your build ID in a bug report

worksforme with linux build 20020305

Comment 2

17 years ago
-> Editor::Core
Assignee: jaggernaut → kin
Component: XP Toolkit/Widgets → Editor: Core
QA Contact: jrgm → sujay
(Reporter)

Comment 3

17 years ago
Sorry, I thought the required information was
deduced automatically from the HTTP requests:

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
Build ID: 2002020415

Comment 4

17 years ago
Hmmmm, I don't see this at all in my Mozilla 03/06/02 Linux DEBUG build.
Reporter, have you tried a recent nightly build?

--> mjudge (caret/selection)
Assignee: kin → mjudge
(Reporter)

Comment 5

17 years ago
Just tried Build 2002030708 -- still broken.

However, I also noticed that it's only broken
on my Slackware 8.0 box.  I also have machines
running RedHat 7.1 and 7.2, and it works on
both of those.  (I didn't notice this before,
because I usually run Mozilla on the Slackware
box, and it's been broken for so long that I
had almost gotten used to it.)

I'll do some extensive testing and post an
update on this later.
(Reporter)

Comment 6

17 years ago
Looks like the bug is caused by the NVIDIA driver included with
XFree86 4.1.0.  When I use the fbdev driver instead of the nv
driver (in XF86Config), the drawing errors are gone.

Comment 7

17 years ago
So can we close this as INVALID?
(Reporter)

Comment 8

17 years ago
I have not looked at the code in question, so I don't think I'm
qualified to make that decision.
 
But there's one thing I'd like to ask before you make it INVALID:
Is it possible that this could be caused by assumptions in your
code that fail on certain display drivers?  (I'm asking because
the driver only causes problems in Mozilla.)
(Reporter)

Comment 9

17 years ago
I think we can close this bug as INVALID.  I just installed the
latest drivers from nvidia.com (NVIDIA_GLX-1.0-2802 and
NVIDIA_kernel-1.0-2802), and now it works again.  Must be some
obscure bug in the version included with XFree86 4.1.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 10

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.