If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<use>-referenced circle isn't in the expected spot, in mask within <symbol>

RESOLVED FIXED in Firefox 52

Status

()

Core
SVG
P3
normal
RESOLVED FIXED
a year ago
8 months ago

People

(Reporter: dholbert, Assigned: cjku)

Tracking

(Blocks: 1 bug, {regression, testcase})

38 Branch
mozilla53
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox51 wontfix, firefox52 fixed, firefox53 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8779572 [details]
testcase 1

STR:
 1. Load attached testcase (based on https://codepen.io/thebabydino/pen/YWRVzG/ )
 2. Look at dots on yin-yang.

EXPECTED RESULTS: Dots should be in middle of swooshes' fattest part, to make a nice yin-yang image.

ACTUAL RESULTS: No light-colored dot is visible; and the dark-colored dot is at the bottom of the image instead of over the white swoosh.
(Reporter)

Comment 1

a year ago
Created attachment 8779573 [details]
reference case 1

Here's a reference case, where I've just replaced the <use> circle-references with actual <circle> elements (with cx and cy set, in place of x/y on the <use> element).
(Reporter)

Comment 2

a year ago
I get EXPECTED RESULTS in Chrome as well as Firefox 37.0a1 (2015-01-01).
I get ACTUAL RESULTS in current Nightly.

So, this is a regression. Range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=29b05d283b00&tochange=d7e156a7a0a6
--> regression from bug 1127507
Blocks: 1127507
Keywords: regression, testcase
status-firefox48: --- → wontfix
status-firefox49: --- → affected
status-firefox50: --- → affected
Version: Trunk → 38 Branch
Blocks: 1262352
Daniel, given jwatt is out right now, can you take a look at this? Do you think we need to hold 49 for a fix here?
Flags: needinfo?(dholbert)

Comment 4

a year ago
Doesn't this merely put us back to the broken state we were in pre bug 932771?

Comment 5

a year ago
I.e. I think we were broken pre bug 932771, then inadvertently fixed (by introducing a different bug) and now were back to broken again.
(Reporter)

Comment 6

a year ago
(In reply to Andrew Overholt [:overholt] (back Aug 31) from comment #3)
> Daniel, given jwatt is out right now, can you take a look at this? Do you
> think we need to hold 49 for a fix here?

Given comment 2 (and Robert's subsequent posts as well), this has been broken since at least Firefox 38, so I don't think it needs to block Firefox 49 in particular, nor does it need urgent attention before jwatt returns (though it'd still be nice to fix).
Flags: needinfo?(dholbert)
Assignee: nobody → jwatt
status-firefox49: affected → wontfix
status-firefox50: affected → wontfix
status-firefox51: affected → fix-optional
Jonathan, are you currently working on this bug now ?
Flags: needinfo?(jwatt)
Priority: -- → P3
(In reply to Daniel Holbert [:dholbert] from comment #6)
> (In reply to Andrew Overholt [:overholt] (back Aug 31) from comment #3)
> Given comment 2 (and Robert's subsequent posts as well), this has been
> broken since at least Firefox 38, so I don't think it needs to block Firefox
> 49 in particular, nor does it need urgent attention before jwatt returns
> (though it'd still be nice to fix).

It also seems a bit obscure (<use> linking to <symbol> containing geometry that is <mask>ed by a mask containing a <use> that links to another geometry element). Do we expect much content to be impacted by this, or enough to make it worth spending time investigating?

(In reply to Astley Chen [:astley] (UTC+8) from comment #7)
> Jonathan, are you currently working on this bug now ?

I'm not currently, but could.
Flags: needinfo?(jwatt)
(In reply to Jonathan Watt [:jwatt] from comment #8)
> I'm not currently, but could.

Thanks. Sounds good to me if you could fix it. :)

Comment 10

8 months ago
Fixed by patch in bug 1325865
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Depends on: 1325865
Resolution: --- → FIXED
Assignee: jwatt → cku
status-firefox51: fix-optional → wontfix
status-firefox52: --- → affected
status-firefox53: --- → fixed
Target Milestone: --- → mozilla53
status-firefox52: affected → fixed
You need to log in before you can comment on or make changes to this bug.