Closed Bug 1294142 Opened 3 years ago Closed 3 years ago

Crash in mozilla::dom::TextTrackManager::TimeMarchesOn

Categories

(Core :: Audio/Video: Playback, defect, critical)

49 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox48 --- unaffected
firefox49 --- fixed
firefox50 --- fixed
firefox51 --- fixed

People

(Reporter: philipp, Assigned: bechen)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(3 files)

This bug was filed from the Socorro interface and is 
report bp-fd2604c9-95ca-448a-82a6-04c952160809.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::dom::TextTrackManager::TimeMarchesOn() 	dom/html/TextTrackManager.cpp:535
1 	xul.dll 	nsRunnableMethodImpl<void ( nsBindingManager::*)(void), 1, 0>::Run() 	obj-firefox/dist/include/nsThreadUtils.h:749
2 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1067
3 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:100
4 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc:228

this cross-platform signature is regressing in firefox 49 and looks related to the work from bug 882718. 
according to crash stats data this is currently making up 0.11% of all browser crashes in 49.0b1.
Assignee: nobody → bechen
Obviously the mTextTracks been null out by CC unlink, then TimeMarchesOn() crash.
Comment on attachment 8780033 [details]
Bug 1294142 - TextTrackManager::mTextTracks is null after CC.

https://reviewboard.mozilla.org/r/70874/#review68260
Attachment #8780033 - Flags: review?(jwwang) → review+
Keywords: checkin-needed
Approval Request Comment
[Feature/regressing bug #]: Bug 1280814
[User impact if declined]: possible crash at the end of playback.
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: low risk, simple fix.
[String/UUID change made/needed]: none
Attachment #8780968 - Flags: approval-mozilla-aurora?
Blocks: 1280814
Approval Request Comment
[Feature/regressing bug #]: 1280814
[User impact if declined]: possible crash at the end of playback.
[Describe test coverage new/current, TreeHerder]: none.
[Risks and why]: low risk, simple fix.
[String/UUID change made/needed]: none
Attachment #8780971 - Flags: approval-mozilla-beta?
Though this is a simple fix, I would still like to see how this does on Nightly51 before uplifting to Aurora50.
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8b20a8ee1249
TextTrackManager::mTextTracks is null after CC. r=jwwang
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/8b20a8ee1249
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
The last crashes on nightly 51 are from 20160815030201, so nothing since 2 days ago on Nightly. That sounds promising for uplift. Ritu, giving it one more day and if there still aren't new crashes tomorrow, let's uplift to aurora + beta.
Flags: needinfo?(rkothari)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #9)
> The last crashes on nightly 51 are from 20160815030201, so nothing since 2
> days ago on Nightly. That sounds promising for uplift. Ritu, giving it one
> more day and if there still aren't new crashes tomorrow, let's uplift to
> aurora + beta.

Yup, looked at the crash stats and nothing shows up on Nightly since the fix landed. So we should be good. I'll A+ for both Beta49 and Aurora50.
Flags: needinfo?(rkothari)
Attachment #8780971 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8780968 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.