Notification audio always comes from computer speakers even when other system source in use

RESOLVED DUPLICATE of bug 1278612

Status

()

Core
Audio/Video: cubeb
P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 1278612
2 years ago
2 years ago

People

(Reporter: Guillermo Huerta [Disabled MoCo account], Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo 2016/05/12 to kinetik, reporter])

When I get notifications in fx50 the audio from that notification goes through my laptop speakers when I have usb speaker plugged in.  The audio comes through even when my usb speaker is muted.
Component: Untriaged → Audio/Video
Product: Firefox → Core
Matthew -- Is this (likely) a regression due to all the work we've done for full duplex? 

Guillermo -- What OS are you using?
Component: Audio/Video → Audio/Video: cubeb
Flags: needinfo?(kinetik)
Flags: needinfo?(ghuerta)
Whiteboard: [needinfo 2016/05/12 to kinetik, reporter]
(In reply to Guillermo Huerta [:guillermo] from comment #0)
> When I get notifications in fx50 the audio from that notification goes
> through my laptop speakers when I have usb speaker plugged in.  The audio
> comes through even when my usb speaker is muted.

As Maire asked, which OS?  Do you know which previous version of Firefox behaved the way you expect it to?  Which site/app is creating the notifications?  Does audio from regular media playback (e.g. YouTube) use the expected output device?  If you're on Windows, can you please attach a screenshot of the Playback tab of the Sound control panel (accessible via the Control Panel, or by right-clicking the speaker icon in the notification area and selecting Playback devices.

(In reply to Maire Reavy [:mreavy] from comment #1)
> Matthew -- Is this (likely) a regression due to all the work we've done for
> full duplex? 

If it's a regression, that's the most likely culprit -- specifically the code around device selection.
Flags: needinfo?(kinetik)
I'm running OS X 10.11.6.

This happens on irccloud.mozilla.com from notifications and videos from youtube when playback begins before the usb headset it plugged in.  In the case of youtube, audio playback goes to the headset if the page is refreshed.
Flags: needinfo?(ghuerta)
Thanks.  This should be fixed by bug 1278612, can you please test a current Nightly?
Flags: needinfo?(ghuerta)

Updated

2 years ago
Rank: 25
Priority: -- → P2
Tested on nightly.  The audio playback for youtube and air mozilla now switches to the USB audio device when plugged in.  The notification do not.
Flags: needinfo?(ghuerta)
That seems to confirm that this was bug 1278612, but I don't know why IRCCloud would behave differently.  Is it possible that it's using Flash for playing the audio notifications?
It seems to be related to the Firefox sending OS X notifications.  I noticed the same behavior from an addon that alerted on another website.
(In reply to Guillermo Huerta [:guillermo] from comment #7)
> It seems to be related to the Firefox sending OS X notifications.  I noticed
> the same behavior from an addon that alerted on another website.

Ah, I didn't realize those were OS notifications.  If so, we don't have control of those and I think they are using the output devices specified in the Sound preferences on the Sound Effects tab under "Play sound effects through".
You right, sound effects were being always sent to my internal speakers.  Looks like this is all complete then.

Youtube audio fix confirmed in nightly.
Excellent, thanks for confirming!  I'll dupe this to bug 1278612 for the part we fixed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278612
You need to log in before you can comment on or make changes to this bug.